So, I don't know how to explain this in words, so I will just put screenshots.

Tried to look for somewhere where this has been reported and solved, but honestly idk the right search terms.

Some info: I first had Windows 10 as my laptop default OS (that it came with), but I had only 4gb of ram so I installed Linux (Pop_OS!). I eventually upgraded my ram 2 days ago, and decided to download Windows 10 back, that was yesterday. I installed GeForce app and updated my GPU, installed Minecraft. I didn't play enough to see the glitch I presume, but then I remembered that I might not have Java installed, so I quit the game and installed Java SE 14. This can be the reason, but I'm not really sure. After downloading some resource packs, I decided to play it a bit more, that's when I realised the glitch, and since then it seemed to be getting worse each launch, but where it appears is random each session.

Specs: GPU: GeForce 940MX CPU: Intel i5-6200U Display: 1366x768 60Hz RAM: 4gb, 8gb (12 total)

P.S. This never happened for the first 2 (or more) years after I first bought it (new), and I am fairly positive my windows installation is not corrupt and the resource packs are not the cause of this

Screenshot 1 Screenshot 2 Screenshot 3 Screenshot 4


1 Answer 1


I think I have fixed it, at least for now. it seems to be a render/chunk loading related issue, from the pattern it was giving occasionally.

It seems optifine was causing the problem at first, so I played on vanilla and it worked. I then remembered something about VBOs improving performance and being related to object rendering or something, so I turned it on while on optifine and that completely fixed it. Not sure why this is, but I will assume this has to do with my hardware, software wouldn't make sense.

Also, resource packs weren't the problem, and I did not download Java 8, and stayed with Java 14 because I know Minecraft downloads its own Java runtime, which is java 8.

Does anyone know why VBOs matter for my laptop? this wasn't the case with the PC.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .