1

My laptop is MSI GL 62M 7RD with 2 GPUs with the better one being GeForce GTX1050. I get decent 45-60 fps for most of the modern games which have really good graphics, but when playing Sniper Elite I get a huge fps drop whenever I try to increase anti-aliasing option even just a notch. Guess it shouldn't be a problem for the GPU to handle such graphics. I suspect that for some reason the game uses the other GPU(which I totally forgot what it was, would be editing this in the future), because I use GeForce Experience software to be able to see fps count on screen and it does not show the fps count when I get into the game.

How can I make the game use the better GPU to get better fps?

1 Answer 1

2

Open the NVIDIA control panel. Right-click on an empty area on your desktop and select the ‘NVIDIA Control Panel’ option from the context menu.

Go to the Desktop menu and enable the ‘Add “Run with graphics processor” to Context Menu’ option.

Return to your desktop. Right-click the app you want to force to use the dedicated GPU. The right-click context menu will have a ‘Run with graphics processor’ option. Select ‘High-performance NVIDIA processor’ from the sub-options and the app will run using your dedicated GPU.

Source: https://www.addictivetips.com/windows-tips/force-app-to-use-dedicated-gpu-windows/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .