In Moviebattles II (a full conversion mod for Star Wars Jedi Knight Jedi Academy), I occasionally experience random crashing while playing online. So far it has only happened while I'm alive in-game and playing as a Sith or Jedi, but I'm not sure if it could happen at other points too (I don't play as a gunner that much). I'm using the Moviebattles II client, and Steam Integration is turned off (it was always buggy for me).

Here is the log in case it is useful. I am using Windows 8.1. The game used to work fine for me but in the past 4 days or so it has started crashing. Is there a fix to this?

  • The error is 'Access Violation', did you try to run the game in administrator mode? Are you sure the files aren't marked as 'read-only'?
    – Mixxiphoid
    Jun 23, 2020 at 17:56
  • @Mixxiphoid I run the launcher in administrator mode, and launch the game through there, I'm not sure if that counts. The game won't work if you don't launch the game through it. As for read-only files I haven't messed with anything so I doubt that's it, and I'm not sure where exactly to look. Jun 23, 2020 at 19:06
  • 1
    Virusscanners and sometimes Windows updates can mark folder as read-only. Make sure the root folder of the game has 'read-only' disabled and apply through subdirectories.
    – Mixxiphoid
    Jun 24, 2020 at 8:25
  • "Access Violation" actually does not generally have anything to do with read-only files -- instead, it's a memory error (the program attempted to access memory that it's not allowed to).
    – Schism
    Nov 17, 2021 at 5:23

1 Answer 1


I read that ragdoll physics on the game can be quite glitchy. I turned it off and after a few hours of playing had no problems (while before it was every 15 minutes or so). This seems to have fixed it. This would explain why it only seems to happen as a Jedi or Sith because the ragdoll physics only take place when lightsabers are used, I believe.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .