-1

I am using openEMU as an emulator to play retro games (snes era) and would like to record the gameplay. I tried using the quicktime app (as suggested in this answer from ~8 years ago), but this uses the built-in laptop mic - this picks up the sound of my fingers pressing on the controller, and and the occasional cough and sneeze. How can I record this gameplay such that the audio is only the gameplay (nothing external)? Also, a 3 minute HD video with sub-par quality using this method takes up 200+ MB; I'm thinking this won't scale well for a game that plays half-an-hour to an hour.

I looked into this via google and came across an app called "soundflower". However, most mentions of this program are 5-10 years old; some articles state that it is difficult to uninstall. In particular, flux forge mentions that the software is not signed by OSX for versions 10.13 and higher. I am using High Sierra 10.13.6 (in case it's relevant). Is soundflower the way to go here, or are there better alternatives?

2

Have you tried OBS Studio? Is available for Windows, macOS and Linux and is Open Source.

You just need to configure the size of the canvas from the options and then add the window of the emulator to OBS Studio as a Game Source (if that doesn't work, use Window Capture).

enter image description here

enter image description here

After that, you can mute the Microphone or Auxiliary Input from the Audio Mixer panel, as seen in the following picture:

enter image description here

(I don't have access to a macOS machine right now, but the features are exactly the same between platforms)

| improve this answer | |
  • I tested the program with another 3 minute recording; it's better than quicktime wrt the frame-rate and file-size (default for me is .mkv), but the issue with the mic still exists. Specifically, it picks up external sounds - if I sneeze, cough, talk, tap the controller hard, etc. I'm having trouble finding the menu of options for the "audio mixer panel" - does this solve the microphone issue? – allthemikeysaretaken Jun 26 at 8:24
  • You can go to View > Docks > Audio Mixer to make the Audio Mixer panel visible. – Lemon Jun 26 at 8:28
  • Thanks! I played with the different settings; I still have the same issue with the microphone. Right-clicking in the panel gives me this menu; these are the microphone settings available by clicking properties; from the advanced properties sub-menu, the output must be on for audio to be picked up. I have played with all combinations of these options. The audio picked up includes external sounds from my environment. Are there other options that can record without picking up external sounds? – allthemikeysaretaken Jun 26 at 8:50
  • Where it says Mic/Aux on the Audio Mixer, click the speaker icon next to the cog wheel to disable the audio from your mic. – Lemon Jun 26 at 8:51
  • On my mac, clicking the speaker icon means no audio is recorded; leaving this icon active records the audio of the game and my environment. Maybe this is different for macs? This video suggests that soundflower is used to configure the microphone before using this program. – allthemikeysaretaken Jun 26 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.