I'm running the latest 1.16 Android version of Minecraft Bedrock under Linux using the mcpelauncher. I want to create my own custom paintings, so I tried to download some and install them so I could see how it was done. However, when I unzip the downloaded file to ~/.local/share/mcpelauncher/games/com.mojang/resource_packs/pack_name it does not show up. I have tried both under settings (global resources) and for a specific map. Both files I found were advertised as being 16x16 - I have read that some larger images may require additional work to get them up and running so I thought this would be the most simple. I also read that it's possible that different versions of Minecraft have different resource pack formats. Both packs I downloaded were advertised for "Minecraft 1.16" although I don't know if there are any other non-Android/Bedrock versions with this same number.

The format of the unzipped directory is a pack.mcmeta containing pack_format 5, as well as a pack.png and an assets folder containing the actual resources.

2 Answers 2


Your problem is a mismatch between the requirements for Java and Bedrock edition RPs. The pack.mcmeta file is for JE, while BE uses manifest.json.

See https://learn.microsoft.com/en-us/minecraft/creator/documents/resourcepack for more information on creating BE RPs.


The documentation that I have been able to find on this is incomplete and unclear. But it appears that for a resource pack on Minecraft Bedrock to show up, at least on Android, there must be a manifest.json file in resource_packs/<name> and in the folder under textures/painting there must be a single kz.png file of a special format. There is a "Vanilla" resource pack that can be downloaded, I followed the "downloading the example pack" link from the "Creating Add Ons" page.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .