I have a new PC with an ASUS TUF X570-Pro (Wi-Fi) motherboard, which has Bluetooth. I have the Wi-Fi/Bluetooth antenna connected and sitting on my desk about two feet from me.

For the last couple of weeks I have been playing games with a DualShock 4 v2, flawlessly. But starting last night, whenever I connect the controller, it disconnects within two or three seconds, and reverts to "Paired" instead of "Connected" in Bluetooth settings. Pressing the PS button reconnects the controller, but only for those two or three seconds.

If I'm in Steam Big Picture Mode, I can sometimes move the cursor one or two items before the controller disconnects, so it is working during those seconds.

The only other thing I can note is that right before it disconnects, the light on the controller flashes bright blue, then goes out. I don't know if that bright blue is the color I've assigned it through Steam, because it won't stay connected long enough for me to check.

Deleting and re-pairing the device, rebooting between pairings, doesn't help; I've done it several times. I didn't change anything else last night when this started. What could be causing this?

  • What Bluetooth dongle are you using?
    – Lemon
    Oct 17, 2020 at 5:03
  • 2
    I'm voting to close as "needs more info" because we don't know what model of controller it is (DS4 v1 and v2 work slightly differently) and Bluetooth dongle and/or chipset (the DS4 is a bit sensitive when it comes to data transmission over BT).
    – Lemon
    Dec 23, 2020 at 15:42

3 Answers 3


When this would happen to me, I would go into my bluetooth settings, scroll down until I see "Wireless Controller" and remove the device. I would then reconnect by holding the menu and share buttons on the DS4 controller for 10 seconds until the light starts flashing rapidly. Click "Add Bluetooth or other device" in the settings, then "Bluetooth" and your device should appear. Once connected hopefully it will not disconnect again.


Remove wireless controller from audio in "Bluetooth & other devices" on show Bluetooth devices, and reconnect again


Same problem happend to me after i installed Star Wars The Force Unleashed 2. Game was unplayable until i remove controller. When i tried to reconnect controller problem same as urs occured. Answer above me suggested something and it helped me, so:

  1. Go to devices and printers in control panel.
  2. Remove Wireless controller
  3. Connect controller with pc
  4. In devices and printers very fast remove device x360 controller (or sth like that), before controller got disconnected.

I think SW TFU2 installed another driver for controller (xbox) and windows tried to install 2 different drivers in same time for one device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .