2

When I start Civilization VI from Steam on Linux (Fedora 32) the game instantly crashes. No error, no nothing. It briefly says that I'm playing it and then returns to saying that I'm not playing it. What might I do to work around this and get the game working?

2 Answers 2

4

Since you are running Fedora, try this:

Check that 'freetype' is installed

dnf list installed | grep freetype

Open Steam, Select the Game, Go to Properties, Select 'Set launch options'

Enter the following line:

LD_PRELOAD=/usr/lib64/libfreetype.so.6 %command%

After that, the game starts without crashing :-) And also, if you exited it once and want to reopen it ;-)

Taken from here:

https://www.protondb.com/app/289070

1
  • This also works. Interesting. Now which answer to accept …
    – Newbyte
    Aug 10, 2020 at 6:15
2

While I have noted that there are multiple methods to solve this issue online, the one that worked for me (which I couldn't find written anywhere prior) was adding this to the game's launch options in Steam: LD_PRELOAD=$HOME/.steam/steam/ubuntu12_32/steam-runtime/usr/lib/x86_64-linux-gnu/libfontconfig.so.1 %command%


More elaborate instructions:

First, right-click on Civilization VI in your library and select Properties...

enter image description here

In the window that appears, press SET LAUNCH OPTIONS...

enter image description here

Now paste the following string of text into the text box and select OK (not CANCEL, important!): LD_PRELOAD=$HOME/.steam/steam/ubuntu12_32/steam-runtime/usr/lib/x86_64-linux-gnu/libfontconfig.so.1 %command%

enter image description here

You should now be able to play the game like normal

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .