There is a known bug that I have fallen into where the Steward will not sell me a house (no dialogue option about it). I also cannot initiate dialog with the Jarl about becoming Thane.

Has anyone discovered a way around this?

By the way, preventing this bug:

Go talk to the Jarl before you do all of the other quests around the city. Do his quests first and get the quest to help out around town. This is just conjecture, but I believe that it is caused by already meeting the requirements to become Thane before you first speak to him.

edit: resetting the NPC does nothing

edit of edit: Perhaps I can force my way into this quest using the console? I know you can begin certain quests with setstage. Can you do the same with the quest to become thane?

  • Did you by chance let Madanach live? Commented Nov 20, 2011 at 21:02
  • @RavenDreamer Nope, I killed him when he told me to go kill that other guy.
    – Jeremy
    Commented Nov 20, 2011 at 21:44
  • Have you retrieved Hrolfdir's Shield for him already? That's the quest that triggers the ability to purchase property and the quest to become Thane. Before you retrieve Hrolfdir's Shield for him, you need to do a Radiant bounty quest for him, too. Commented Nov 20, 2011 at 22:03
  • 1
    @RavenDreamer Yup, I did all that stuff. This is a bug.
    – Jeremy
    Commented Nov 20, 2011 at 23:02
  • I have also hit this bug, and got to the point that I've done the same bounty at one of the redoubts 3 times lol I think I triggered the bug by not taking the Buy House option when it was offered with first contact, I didn't have enough money at the time, and was following the Whiterun process...Do quest, get Title and then buy House. Will try console command above...very excited now ;)
    – user15963
    Commented Dec 5, 2011 at 21:04

2 Answers 2


Console command: setstage favor250 20

favor250 is the quest for becoming thane of Markarth

stage 20 is when you have bought a house and done 5/5 objectives.

After becoming thane by talking to the Jarl, you can then talk to his steward, and he will finally sell you a house, for some stupid reason.

  • Tried your fix, and it worked like a charm, thanks a bunch! it's the best house i seen in the game!
    – user15237
    Commented Nov 24, 2011 at 22:04

I too have fallen into the same bug, but started to test out how so many people own the house and others don't. I believe its the order you complete quests.

If you complete the prison break then the Jarl's two other quests the Steward seems to bug out. But to fix this problem you need to complete the two quests from the Jarl before you start the prison break quest line.

If you can try this out for me and please confirm if it works for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .