0

I'm using a Macbook and have already tried to use a different mouse, but got the same outcome. I've also tried changing the Game mode and still the same outcome occurs. For some reason, my left click just switches to place. This happens to every type of block as well.

2
  • 1
    What else have you tried? Have you accidentally rebound the keys? Sep 4 '20 at 12:49
  • How about your right click? Does it place blocks as well? Sep 5 '20 at 3:44
1

Just a guess, but have you rebound your Sneak button from Shift to Control?

In MacOS, Control+click is translated to right-click so, if Control is your sneak button, anytime you're sneaking all your clicks will become right-clicks.

-1

I'm unsure about macbooks and how they work, however may I suggest rebooting your computer, and making sure you are not using any snapshots. If you continue to see this problem, make some backups for your worlds to be on the safe side.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.