3

I am attempting to play Watch Dogs on Windows 10. The game ran fine at low settings on a Windows 7 PC (at least 30-35 fps) but Windows 10 does not give me even 20 fps.

I have dual booted Windows 7 and Windows 10 for comparisons. The specs are as follows:

  • CPU: Intel I3 5005u @ 2GHZ
  • RAM: 4 GB DDR3 ram 1600mhz
  • GPU: Intel HD 5500 Graphics
  • OS:
    • Windows 7 (latest updates installed), vs
    • Windows 10 1909

I have all the latest drivers for both OSs.

One other thing I noticed is that after exiting the game in Windows 10, CPU usage was always around 30-50%, RAM usage was around 3.1 GB of 3.9 GB and in Windows 7 CPU usage was not going above 20% and even ram usage was only 1.5 GB - 2GB.

I even edited the xml file to put graphics setting at lowest in Windows 10 but no good happened.

How can I increase the performance so that the game runs well on Windows 10?

3
  • 1
    Might be a driver issue. Are you using the same driver version in both Windows 7 and 10? Sep 13 '20 at 8:26
  • @galcticninja Yes both the OS have same graphics driver which was last updated in Feb 2020.
    – Crispy Con
    Sep 13 '20 at 13:35
  • I think this might be a Windows 10 issue. It seems that Windows 10 uses more system resources, especially RAM, compared to Windows 7. I've noticed the same in my other 4 GB RAM PCs. They don't fare too well with gaming in Windows 10, even though they did just fine in Windows 7. Mar 24 at 9:36
3

Try disabling Windows 10's Game Mode

Despite Microsoft's claims to the contrary, it seems that some people have been getting poorer gaming results with 'Game Mode' enabled. What's more, it's enabled by default - so if you've done a fresh install of Windows 10, it's probably still turned on. To disable it:

  • Click Start -> 'Settings' Cog
  • Click 'Gaming'
  • Along the left-hand menu, find 'Game Mode'
  • Click the toggle to turn it off.
4
  • Hi @Robotnik! Thanks for reply. I tried playing Watch Dogs with Game mode off and noticed a minor positive result. However this still didn't make the game as smooth as in Windows 7. Any ideas why is this happening?
    – Crispy Con
    Sep 14 '20 at 3:03
  • 3
    @CrispyCon - Without knowing specifics of your PC (including stuff installed on it) I can only guess from here - but generally I would say that Windows 10 tries to do a lot in the background, and so do a lot of third party applications - try disabling/removing background processes, stuff from startup etc.
    – Robotnik
    Sep 14 '20 at 4:16
  • I have already disabled all startup apps except audio driver app and Windows Defender. Even my Windows update is disabled. I think I'll need to close some background processes every time I am about to start the game or install unofficial Windows Lite xD. Anyways thanks for assistance.
    – Crispy Con
    Sep 14 '20 at 4:33
  • @CrispyCon no problem, glad to help even if it's just a little bit :). Best of luck with your search! Let us know if you find the culprit :)
    – Robotnik
    Sep 14 '20 at 4:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.