1

I've been trying for weeks to solve this problem. I'm using Minecraft Java Edition 1.13.2, and I'm trying to use the following commands in /execute.

/title @p times 10 30 10
title @p title {"text":"Level 1","color":"red","bold":"true"}
title @p subtitle {"text":"Level 1","color":"red","bold":"true"}

It worked when I didn't use my /execute command at the start.

(/execute as @a at @s if block ~ ~-0.35 ~ gold_block run (command)) but when I tried to the execute command, it didn't show up. Also, when I tried doing it and turning the OP logs on, nothing popped up.enter image description here

Please I really need help with this.

4
  • 3
    That execute command will run once. Are you using it on top of the gold block, or not? I would also recommend changing -0.35 to -1 unless you're using snow blocks, as it provides more accuracy.
    – Corsaka
    Sep 14, 2020 at 11:13
  • @FireRoz Which command(s) are you using /execute with? Also, is your command(s) repeating?
    – ginkgo
    Sep 14, 2020 at 11:26
  • @Corsaka yeah it executed the playsound and the /tp but it didnt execute the /title @p subtitle... and it didnt execute /title @p title
    – FireRoz
    Sep 18, 2020 at 13:19
  • @ginkgo im using /title @p title, /title @p subtitle, /tp, /playsound. i dont know what you mean by "is your commands repeating?". also, if you mean repeat by what i think, it repeats because the /execute is typed in a repeated command block.
    – FireRoz
    Sep 18, 2020 at 13:20

3 Answers 3

1

If you are running those commands every tick, then the issue is that the title command also plays every tick. And since it does, it does not have enough time for the title to fade in before the next title is played.

You can fix this issue by changing the fade in parameter from:

title @p times 10 30 10

to:

title @p times 1 30 10

0

From your logs, you appear to be teleporting. Wouldn't this mean you are no longer standing on the gold block, and therefore the title isn't shown?

Try show the title first before the player is teleported.

-1

There's a limit to how many commands you can put into 1 block, so for example, in gold block there can be 3 commands in max (every block in minecraft can be only 3 commands in max). So I tried adding commands into Purpur Block, and it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .