1

It seems that my resource pack has an error, specifically with lava flowing. My image is 16x256 (its an 8x8 texture pack) so it should work normally. Has anyone had this issue and knows how to solve it? Here's what it looks like:

Lava Flowing

Obviously I want it to all look flush like normal lava. Here's the lava_flow image:

lava_flow

Any ideas on the issue? I looked it up and found that if the dimensions aren't divisible this might happen but the vanilla file is 32x512 and 16x256 is exactly half of that.

12
  • How did you made it? What have you tried to fix it?
    – Lemon
    Oct 29 '20 at 0:34
  • What do you mean by how I made it? I used Paint.net to make it and this is the only texture I have issues with
    – Penguin
    Oct 29 '20 at 0:36
  • I have never used Paint.NET, but can you check if the texture is being exported with compression?
    – Lemon
    Oct 29 '20 at 0:45
  • @Lemon I don't think paint.net is the issue because I use the exact same settings for every image, also I've enabled and disabled compression before and Minecraft still renders it
    – Penguin
    Oct 29 '20 at 1:05
  • 1
    @Z9. This isn't a mod?
    – Corsaka
    Nov 3 '20 at 14:42
2
+50

Most likely, the 16x256 version of the pack isn't being scaled up correctly. Minecraft is very specific about exact file dimensions, and doesn't handle scaling too well.

Upgrade to 32x512.

2

Flowing lava at certain flow amounts has a block model. So, while the side of a full block of flowing lava is a normal cubic flat block, the flowing onto the ground parts have a block model, and rather than applying a flat texture the texture is used as a UV texture. Since the texture is being used as a UV texture and being downscaled, it doesn't have all the pixels needed to complete texturing the model. All that needs to be done to fix it is to scale it up to double by a Neighboring Pixels scaling method. This way, the half as large size is visually seen but technically the image is the same size as the vanilla.

0

It looks like the lava texture might be one solid, so you can just cut it down to 16 by 16, instead of having it the same. If you don't want to, you have to have a MCMETA file with the text below. The pack needs to have lava_flow.mcmeta and lava_still.mcmeta in it, as well.

{
    "animation": {
        "frametime": 2,
        "frames": [
            0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,18,17,16,15,14,13,12,11,10,9,8,7,6,5,4,3,2,1
        ]
    }
}

I hope this helps!

5
  • 1
    Bedrock doesn’t have MCMETAs and what do you mean cut it down to 16x16? The dimensions of the original lava flow are 32x512
    – Penguin
    Oct 29 '20 at 13:52
  • The default lava animation has 20 textures, but yours might only have 16 and, since the default animation goes through textures 0-19 and then backward from 19-0, it has to say which texture it's using for each frame, so it gets confused when your animation doesn't have textures 16-19. Oct 29 '20 at 13:55
  • Or if you just want the animation to go from 0-15 and then repeat you could copy lava_flow.png.mcmeta into lava_still.png.mcmeta (and change "frametime" to 2 if you want it to go at the same speed as normal). Oct 29 '20 at 14:00
  • 1
    Bedrock still doesn’t have MCMETAs and also my image has the same amount of frames, and there is no missing texture for the majority of the flowing lava which tells me that every frame is being filled, just something is wrong when it tries to do the corner model
    – Penguin
    Oct 29 '20 at 16:42
  • Hmmm. Let me think about it. Oct 29 '20 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.