For some reason Skyrim only says "Can't sleep/wait in this location" no matter where I try to wait or sleep. There are no answers anywhere else, and this isn't caused by any quest or location as I have tried everything. I have no saves before this and my character is level 20 so starting it over would be a pain. I own Skyrim on the PC.

  • 5
    IS this your first Bethesda game? Because when playing any Bethesda game, you should always, always keep multiple save files.
    – Wipqozn
    Commented Nov 21, 2011 at 23:12
  • What platform are you on? Some problems are easily fixable with the console on PC when they can be very difficult to solve on PS3 or 360. Commented Nov 22, 2011 at 0:09
  • Oh sorry I forgot to add that it was on the PC. I edited the body to reflect that.
    – Mikael
    Commented Nov 22, 2011 at 0:35
  • 2
    The game will refuse to let you sleep/wait if there are hostiles nearby. Have you tried simply going somewhere else, or is this persistent across multiple locations? Commented Nov 22, 2011 at 1:31
  • Normally skyrim auto-saves every door or dungeon you go through.
    – Sir Ksilem
    Commented Jan 13, 2014 at 10:26

5 Answers 5


As I don't have enough rep for comments, let me answer you here.

Sometimes if you have a bounty on your head, the guards will be after you, thus you can't wait/sleep in or around the city..


I had the same problem, except for the fact that I was in the middle of the final chapter of the dark brotherhood's quests and a guard could appear more or less at any place, and any time and ruin my sneaking progress.

Anyway, whenever I tried to sleep, a guard would appear somewhere close by. Have you been scouting around after you receive the message? Perhaps they won't appear if you are in the middle of a dungeon.

The only way I could solve it was by getting arrested and paying my bounty, then going back to the same place (dropping all my stolen goods beforehand of course).


Late answer, but I had the exact same prolem: it simply told me "you cannot wait/sleep at this location.
The thing that fixed it for me was that I simply transformed into a vampire lord* (from Dawnguard DLC) and then transfored back. Miraculously it all worked after that. I hope this helps.

*If you dont have Dawnguard I'd imagine a werewolf transformation would also work.


There is a bug in 1.1 of Skyrim that prevents someone (in certain circumstances) to not be able to press "enter" when trying to Wait or Sleep. I can't upgrade to 1.2 yet I spent hours trying everything and finally found the answer:

If you press and hold the icon that allows you to move the slider left and right and then press "E" AGAIN. It will cause the intended effect.

Wait: Press E, click and hold the slider at the time you wish and (while still holding the slider) press E again, and wait that amount of time.

Sleep: Same mojo.


Press E instead of Enter.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .