Nowadays, I am playing Castlevania: Lords of Shadow using my PC with a keyboard.

Unfortunately, other ports on the case are broken and I can't attach a controller. Also, I dislike wireless controllers.

I'm stuck in one of the stages and I know it requires rolling the shock button in a controller.

This is that exact stage. The titan throws a rock at my character and I should grab the rock with my bands, rolling it around myself, and throw it back to the Titan.

To roll the rock, the player should perform the shock-button rolling (which is highlighted in the game itself in a hint). But the problem is that it's so hard to perform this action using a keyboard.

I tried to push the arrow directional keys repeatedly and to push A, S, W, D keys repeatedly; but both techniques have failed.

Any advice?

1 Answer 1


The game may be expecting the full input with the diagonal directions, like up, up+left, left, left+down, and so on.

Have you tried pushing W, then pressing A without releasing W, release W, press S, release A, press D, release S, press W, ... ?

Making the sequence: W, W+A, A, A+S, S, S+D, D, D+W, W

Another option would be to try a software like GlovePIE or AutoHotkey and create a macro to perform the required input.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .