I have an… unusual problem.

What's my head doing over there?

What? How'd it happen? No, no, that isn't impor— Okay, fine. It might have something to do with the tim command, a bandit chieftan, and an accident with an ebony greatsword. But that's all you're getting out of me!

Now where was I? Ah, yes. Wherever I go, my head seems to be a few steps behind me, catching up at odd intervals only to be left behind again. I just stopped to mine a corundum deposit, and my head fell to the ground and started rolling down the mountain! Very embarrassing.

How can I fix this? I was actually wandering around without any head at all for a while, but was able to restore it by sexchangeing twice. Sadly, it doesn't appear to have been bolted on properly when it reappeared. I can't even hide my deformity with a hat!

I'm making my medical records available to anyone wishing to study my condition.

  • 168
    This is how you form a question. – Domocus Nov 22 '11 at 5:15
  • 29
    Have you tried sewing it back on? – Coomie Nov 22 '11 at 5:48
  • 92
    Put a bucket on your shoulders and call it a day? Everyone else in Skyrim is doing it! – Raven Dreamer Nov 22 '11 at 6:00
  • 7
    Did the bandit chieftain preform a finishing move on you? – Arkive Nov 22 '11 at 6:35
  • 38
    Lesson: console-activated game modes meant for developer debugging-convenience aren't safe. But they are amusing. – SevenSidedDie Nov 29 '11 at 19:05

When you get killed by a decapitating strike, a flag gets set in the game state to denote that an animation should be played showing that you got decapitated. Upon loading the game; the animation of the body appears to be overridden by another animation (eg. your character wobbles even though your standing still), so the flag does not affect the body part. However, it does affect the head...

I see two ways to get rid of this annoying stuck flag:

  1. Get someone to do a decapitating strike on you without being in immortal mode.

    If lucky, the flag is removed upon death. If unlucky, it just adds and removes a second flag...

    The above fix won't work, once you get killed it will just reload the save game again. In a similar vein the other fixes mentioned in this question (and elsewhere) do not work because they do not clear the flag from the save game. Editing the save game seems to be a necessity to fix this.

  2. Get two save games, the one right before and after the incident. It might be more feasible to try to reproduce this and get two save games in which there are less changes...

    Then, use Notepad++ to do a regular expression replace to change :: into \n.

    Now you can use WinDiff and set it to show right-only lines. If done properly the amount of changes would be minimal and if you look at the lines containing _var variables you could easily figure out which flag affects this. Replacing one character should yield the flag invalid, do however not add/remove characters as that might break the file.

| improve this answer | |
  • I can't think of a way to tell whether I've been decapitated again and the saves are too far apart to be very helpful (about 7 hours of play; I'd just discovered Quick Save and got lazy), so I wasn't able to find a variable that did the trick. I'm going to start a new character and see if I can't reproduce the problem so that I have a better test case. – Ben Blank Dec 1 '11 at 13:50
  • 2
    @BenBlank: set DecapitationChance to 100 and set KillMoveRandom to 100 seem to ensure a decapitating blow is dealt to you, together with tim that should allow you to reproduce this behavior. I'm currently near a camp with multiple guards and a dragon in the air disallowing me from saving when I attack the group of guards, running too far away causes the game to crash and a quick save seems to get broken because I'm in a fight. So, I can't test this in the current situation but might try again at a later point where it would result in a smaller fight and I can kill the decapitators... :) – Tamara Wijsman Dec 1 '11 at 16:13
  • On your save game, I tried using tim and the above mentioned commands (also with low KillMoveRandom values as I'm unsure if it contributes to decapitation) till I received a decapitating blow; then, when I was down on the floor I used tim again in order for the game to see me as dead. Apparently that doesn't work as it just reloads the save game, I think the only thing left to do is obtaining two save games that consist of a minimal change in game state. Then do a manual or binary diff... – Tamara Wijsman Dec 1 '11 at 16:40
  • 1
    After trying for about an hour, with various values for DecapitationChance and KillMoveRandom as well as opponents, I can't seem to get a decapitation at all. Who/what were you fighting and how were they armed when you managed it? – Ben Blank Dec 1 '11 at 17:19
  • @BenBlank: I'm starting to think I never got decapitated by an enemy before... o_O Is there a cut scene supposed to happen when the enemy does that? Because I thought if they lift their weapon high in the sky and then knock me down on the floor it would be a decapitation, but now I'm starting to think that that different animation is just the kill move and not an actual decapitation. Have you tried a troll? Or a bandit chieftan like you mentioned in your question? – Tamara Wijsman Dec 1 '11 at 17:40

Have you tried werewolf transforming? That seems to re-initalize your body/race.

At the very last resort, you could do showracemenu and change nothing, but that has side-effects.

| improve this answer | |
  • Well, this gets me closer than anything yet. Unlike sexchange, this not only causes my head to reappear, but also attaches it correctly. Unfortunately, helm graphics still don't show and my head vanishes again when I exit and restart the game. :-( – Ben Blank Nov 30 '11 at 7:51
  • The werewolf change does not work. It is temporary fix, if you equip a helmet you will see that the player is bald. Also it does not work if you go to werewolf, sexchange, werewolf out, sexchange again. Also it does not work to change in ANY other animal and back to player. I have found that the game value is stuck at "islimbgone 1".The number 1 is the value for the model's head. I don't know the command to force the game to reload the player model. – user18021 Jan 9 '12 at 9:51

I've got the same problem and I posted about this on the Bethesda Forums about a week ago. There a kindly young chap dropped me with some wisdom, although not entirely helpful, it was a piece of the puzzle. He claimed that this problem had been posted before, and said the sexchange was necessary, but that I also needed to 'remove gory neck graphic'.

He said this problem can be fixed in console by typing in the following:

player.removeitem 000DB5D0 1
| improve this answer | |
  • Can you link to your forum post? I'm digging into this now. :-) – Ben Blank Dec 18 '11 at 20:51
  • 1
    Here's the original post: forums.bethsoft.com/index.php?/topic/… There should be a link to Shazbit's "common bug fixes" thread at the end of one of his posts. He still hasn't found the id for it from what I've read. – Nikosuave Dec 18 '11 at 23:01
  • I'm sorry, not Shazbit, the other gentleman in the thread, "noodlesdefyyou". – Nikosuave Dec 19 '11 at 1:00
  • 1
    Ben! I've found the id in question. The previous format should work, and put this: "player.removeitem 000DB5D0 1" instead of the 'remove gory neck id'. Safe travels, sir. – Nikosuave Jan 9 '12 at 14:55
  • 3
    Interesting! This does indeed seem to have removed my neck stump — I can now see the inside of my armor by looking into the neck hole — but it didn't reattach my head. – Ben Blank Jan 10 '12 at 17:20

Change into a werewolf then change back!

Use these console commands to gain the werewolf abilities if you haven't gotten them in game yet.

player.addspell 00092c48
player.addspell 000a1a3e

Change then change back. Once you are done use these console commands to go back to normal.

player.removespell 00092c48
player.removespell 000a1a3e

Just don't do it in town or near anyone else!

| improve this answer | |

Based on your comments, tim = toggle immortal mode. A thief and an ebony broadsword. Did you die and then make yourself immortal or something? If that's the case, maybe you're still dead? Have you tried resurrecting yourself? Might try player.resurrect. But I'm just guessing what's going on here. Pure guess. Nothing concrete to back it up. Mostly cause my head is still attached.

| improve this answer | |
  • 3
    Sadly, this doesn't reattach my head so much as it crashes the game. Interesting idea, though. :-) – Ben Blank Nov 30 '11 at 7:30
  • tim wouldn't have any effect if he was already dead. All it does is negate the damage from any hit which would inflict enough damage to kill you - but this is apparently independent of the "would you die?" check used to trigger finishing moves, so they still go through, causing potentially... unusual results. – Dave Sherohman Nov 30 '11 at 14:46
  • This isn't a final answer to the question, it should be a comment. – Tomáš Zato - Reinstate Monica Jul 20 '16 at 12:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.