2

Recently, I made a Minecraft server to play with my friends on. I'm hosting it off an old laptop and playing it from my PC. I have port forwarded my router and I'm using NoIP as a hostname for my friends to join through, and I connect through my public IP (which I get through searching "my ip" on google on the laptop). At first, there were no issues and I played for about an hour with friends before I got randomly disconnected to the multiplayer screen with no error.

I could no longer ping my server and it would look like thisthis I got this error when joining this

My friends stayed connected however I couldn't regain connection so we decided to leave it. I made a post on this forum however about 2 hours later, I checked again and I could play fine, so I removed the post. I played for a bit longer then went offline and there were no more issues. I tried logging on this morning but only to get this issue again.

I tried:

  • refreshing the multiplayer menu
  • restarting Minecraft
  • relogging my Minecraft account
  • restarting the server from my laptop
  • restarting my PC
  • restarting my laptop
  • allowing Java and the Minecraft launcher access through the firewall
  • checked the ports (25565 is open)
  • connecting through "myip", "myip:25565", the NoIP hostname, "localhost" and "localhost:25565" (none worked, and obviously localhost wouldn't)

I can play other Multiplayer servers (such as Hypixel, Manacube etc) but I just can't connect to my server whereas my friends can. I'm not sure why this is the case, any help would be appreciated!

2
  • 2
    If the Laptop (Server) and the PC (Client) are connected to the same physical network then I would advise using the local IP address and not the external IP address as its likely that you are running into some form of NAT related issue. – CraftyB Dec 2 '20 at 11:44
  • I just switched to connecting via the Local IP address and that seems to have fixed the issue consistently, don't know why I didn't think of this. Thank you so much! Post it as an answer so I can accept and award the bounty :) – xupaii Dec 2 '20 at 15:50
1
+50

If the Server and the Client applications are connected to the same physical network (wired and / or wirelessly) it is best to attempt to connect using the local IP and not your external IP address. (Please note that firewall rules may need to be considered to incorporate the external & internal connections).

Connecting to a device that is internal to your network using your external IP can sometimes result in NAT issues, this can be for a few reasons and is off topic for this stack exchange channel. (Google "NAT Loopback" for further information on the topic.)

4
  • Can't you just run a cmd command to allow your own computer to connect to itself? – Penguin Dec 2 '20 at 16:40
  • Yes if you are running the server and the host on the same PC then you can use "localhost" or "127.0.0.1" to connect to itself. However in this case the OP was trying to connect to a different device in their network using their external IP (known as "NAT loopback") this inherently can have network issues due to routing etc. – CraftyB Dec 2 '20 at 16:53
  • no not localhost, can't you run a cmd command that allows your computer to connect to its own IP address? – Penguin Dec 2 '20 at 17:14
  • @Penguin You can connect to your own IP address without having to use any commands. Firewall settings is an exception to this but you wouldn't generally set these via CMD. I think its likely that you are referring to "ipconfig" to identify your local IP. – CraftyB Dec 3 '20 at 10:39
1

This means that the server failed to reply to the query. This means, in general, that the port is incorrect, the server-ip in server.properties is set, or that the server may be using all of your wifi speed, leaving none for your computer to connect. Ensure the port is correct, and you could also try deleting the server.properties file to ensure something was not set incorrectly.

7
  • There was no server-ip set in the properties file, and deleting the file didn't resolve the issue either. As mentioned in the post my friends can still join whereas I can't. Also I don't believe that my Wi-Fi is the issue as I usually get 200-300Mbps download and 20-30Mbps upload. – xupaii Dec 1 '20 at 22:04
  • 1
    Does the server show you as logging in? The console should say something whenever a new connection is attempted. – valkyrie_pilot Dec 1 '20 at 22:13
  • I had ports 19132-19133 opened on UDP protocol, I disabled that and I can now ping the server, I assume that was interfering? Nonetheless, thank you for your help! <3 – xupaii Dec 1 '20 at 22:13
  • It very well could have been. – valkyrie_pilot Dec 1 '20 at 22:15
  • Never mind, I thought it was fixed but after another refresh the server can no longer connect.. – xupaii Dec 1 '20 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.