I'm currently unable to make any progress in the "I fought the law" mission in Cyberpunk. I've done everything this part of the mission has to offer. I defeated all the enemies in the building, went down into the Red Queen's Race, initiated the braindance sequence in one of the rooms, and had River come down and save me. I left the area and it gave me a new mission, "Find a way into the Red Queen's Race". I assumed it was just a bug and that I would eventually proceed with this story branch, but after a day of doing side-missions and gigs, I'm still softlocked and unable to finish the mission.

Here's what the bug looks like: enter image description here

enter image description here

I tried closing and reopening the doors, going down into the Red Queen's Race to see if I had the option to do the braindance sequence again (no luck), skipping time, calling/texting River, nothing worked.

3 Answers 3


I ended up watching a playthrough of the mission that told me a few things, more importantly what I was missing that was causing this bug. I still needed to talk to River in that scene where we apprehend Detective Han. I drove back to that place and River was there waiting for me, I entered a dialogue with him and the mission continued. The bug was still there though, after I talked to him it was still pathing me to the Red Queen's Race. All I had to do was redirect the map to Elizabeth's place and the mission finished.

  • 1
    Please mark this as accepted
    – Penguin
    Commented Dec 20, 2020 at 2:38

Similar, got all the way to convo with River and Han when next objective "Call Elizabeth" popped up but map directed me back to club. To find apartment:

  • Open journal
  • Left click on Elizabeth objective (on the right side of the screen, you can select individual objectives within the mission page)

Map will then direct you there. As you say @mimky quest completion is not bugged luckily!


There appeared to have been a glitch with fast travelling prior to the encounter with Tyger Claw members, which was patched in version 1.05 of the game:

Fast travelling before the encounter with Tyger Claws no longer breaks progression in I Fought the Law.

You said you left the area, which I am assuming you mean fast travel, but if not, I would try to see if this is resolved with the patch now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .