1

I recently installed Grand Theft Auto IV on my PC (Intel i3 6100, 4GB RAM, GT 710 2GB DDR3). I installed a few car skins and the game started to drop frames at High settings. So I reduced it to Medium to avoid frame drops and lag. But then I realised that the game was using only 300-400MB of VRAM on Medium and 700-800MB on High. Despite my GPU having 2048MB of VRAM, why am I not able to run GTA 4 on high with no frame drops and lag? Is there an explanation and solution? Why is it not using the full (or near full) capacity of my GPU?

1
  • 1
    I think I should clear this misconception: Too much RAM does not make your PC faster, but too little RAM makes it unusably slower. If the game doesn't use all VRAM, then it doesn't need it and it won't run faster just from using more.
    – Nolonar
    Jan 5 at 5:20
3

Despite my GPU having 2048MB of VRAM, why am I not able to run GTA 4 on high with no frame drops and lag?

GTA IV's PC port is very unoptimized.[1] [2] [3] Its successor, GTA V, will usually have better performance on the same PC.

Why is it not using the full (or near full) capacity of my GPU?

I believe that's to be expected for a 2008 game. 2 GB graphics cards were a novelty back then.

To improve performance, see the PC Gaming Wiki's GTA IV article. I'm quoting some of the relevant parts here:

Large framerate drops on densely detailed parts of the city

  • Lower the view distance to 25 or lower. Anything higher may cause drops in performance when looking at the city's skyline or at densely detailed areas (particularly Middle Park) for very little visual gain.
  • You may also increase your performance significantly while minimising pop-in and graphical glitches by setting the Detail Distance between 10 and 40.
  • If you need very high framerates, it is recommended that you disable shadows as they are CPU-intensive and also reduce the Vehicle Density to around 40 (33 is the console default if you want a "vanilla" experience).
  • Keeping Vsync enabled (with the shadows disabled) may help maintain close to stable 60 FPS even on old Core 2 Quad CPUs.
  • Alternatively, you can also try out disabling Clip Capture in the "Game" option in main menu and setting -mispecaudio which can unload the CPU to some extent depending on your specs and -noprecache in some scenarios and -disableimposters excluding flying.

Game will load with minimal graphics settings and won't let you change them

  • For video cards that have more than 2 GB or VRAM the game will run but won't let you change the graphics settings to anything better. In order to force the game to allow the changes, load the game's executable with this extra parameter: -norestrictions.

  • Bypass graphics restrictions on Steam version

  1. Open your Steam library.
  2. Right-click on 'Grand Theft Auto IV' and select 'Properties'.
  3. Press the Set Launch Options... button.
  4. Enter -norestrictions into the text field, press 'OK'.
  5. Start the game.
  • Bypass graphics restrictions on other versions
  1. Go to ''.
  2. Create a new text file in this folder and name it commandline.txt.
  3. Open it and add the string -norestrictions to it.
  4. Save the file.
  5. Start the game.

If on Windows 10:

Disable fullscreen optimization

  • Go to the installation folder.
  • Right click on GTAIV.exe and enter its properties screen.
  • Under the compatibility tab, tick 'Disable fullscreen optimisations' and click 'OK'.

There are also other performance-improving tips on the same PC Gaming Wiki article that you might want to try.

1
  • Thanks for the answer mate. I agree with your GTA 5 point. Despite my PC being eligible to be classified as a potato, my experience was much smoother with GTA 5. I play GTA 4 just to experience the mind-blowing vehicle physics. Jan 6 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.