I was trying to modify a tool's attack speed NBT, and stumbled across this thread. I tried to use the command, but it only seems to reduce the actual attack damage of the tool, and not the attack speed. Is there an updated way to increase the attack speed of a tool effectively, and without reducing the damage dealt?

  • I assume you did, but did you format the command correctly for 1.13+? /give <target> <item>{<properties>} <count>? I assume you did if you got it to even go through but should probably check just in case
    – Penguin
    Jan 7, 2021 at 16:30
  • @Penguin yup, the item showed that there were 2 nbt tags on it, but the attack speed didn't change. the damage was decreased to 1 Jan 7, 2021 at 17:02
  • What was the exact command you ran? Jan 8, 2021 at 17:57
  • @randomuser922 the command was /give @p diamond_sword{AttributeModifiers:[{AttributeName:"generic.attackSpeed",Name:"generic.attackSpeed",Amount:1000,Operation:0,UUIDLeast:1,UUIDMost:1}]}. Did this work for you? Jan 9, 2021 at 2:09

1 Answer 1


The following command was generated from MCStacker using the give command generator.

/give @p diamond_sword{AttributeModifiers:[{AttributeName:"generic.attack_speed",Name:"generic.attack_speed",Amount:1000,Operation:0,UUID:[I;-756158760,-1248440979,-1426007026,1776833309],Slot:"mainhand"}]} 1

This command worked for me. As for your command, it seems that Minecraft requires a UUID for attribute modifiers, instead of a UUIDLeast and UUIDMost.

  • while this command does seem to increase the attack speed, it also decreases the attack damage. how would you prevent this from happening? Jan 12, 2021 at 23:26
  • @12rhombiingridwnocorners what does it say for the attack damage? Default is 7 for diamond sword. It shouldn't do anything to attack damage. It works as intended for me(attack speed it up, and attack damage isn't touched). Jan 13, 2021 at 1:22
  • sorry for the late response, it didn't list the attack damage, only saying '+1000 Attack Speed'. Is there a way to preserve the 7 attack damage, or do you need to add it explicitly in the command? it's strange that it doesn't affect your attack damage. are you playing on 1.16.5? Jan 17, 2021 at 15:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .