I've downloaded Destiny 2 on an external hard drive to play on my laptop, but I'm not able to play the game. Before, normally, I even see my Guardian, the game crashes with the error 'Problem reading game content'. I've tried every method I've found online but nothing is working.

My specs:

Version 10.0.19042 Build 19042
Other OS Description    Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer LENOVO
System Model    81F5
System Type x64-based PC
System SKU  LENOVO_MT_81F5_BU_idea_FM_ideapad 330S-15IKB
Processor   Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz, 1801 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date   LENOVO 7SCN17WW, 24/03/2018
SMBIOS Version  3.0
Embedded Controller Version 1.17
BaseBoard Manufacturer  LENOVO
BaseBoard Product   LNVNB161216
BaseBoard Version   SDK0J40700 WIN
Platform Role   Mobile
Secure Boot State   On
PCR7 Configuration  Elevation Required to View
Windows Directory   C:\WINDOWS
System Directory    C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale  United States
Hardware Abstraction Layer  Version = "10.0.19041.488"
Username    LAPTOP-QKOK69LO\(my name)
Time Zone   GMT Standard Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory   7.91 GB
Available Physical Memory   1.68 GB
Total Virtual Memory    17.4 GB
Available Virtual Memory    6.77 GB
Page File Space 9.48 GB
Page File   C:\pagefile.sys
Kernel DMA Protection   Off
Virtualisation-based security   Not enabled
Device Encryption Support   Elevation Required to View
Hyper-V - VM Monitor Mode Extensions    Yes
Hyper-V - Second Level Address Translation Extensions   Yes
Hyper-V - Virtualisation Enabled in Firmware    Yes
Hyper-V - Data Execution Protection Yes

(The external drive has 1.8TB free on it)

How can I get the game to work?

  • 1
    This is on Steam, correct? Have you tried verifying game content using the right-click menu? Jan 8, 2021 at 20:16
  • Yeah, it’s on Steam (that’s why I tagged it lol) and I’ve tried verifying but it doesn’t work.
    – mreyeball
    Jan 8, 2021 at 22:50
  • This is speculation, but your USB drive may not be fast enough. Destiny requires really high I/O speeds to be able to run. Unless it's running USB 3.1 or better, it's running quite a bit slower than the SATA3 standard.
    – theMayer
    Aug 14, 2021 at 16:54
  • You know what? A few days ago I came to the same conclusion myself. Judging by the awful file transfer speed, especially when loading games from the drive, and the fact it's an HDD instead of the SSD I presumed it simply to not have the transfer capability to run such a huge game as Destiny. Ah, well. My FPS would probably have capped at 10 anyway ;-;.
    – mreyeball
    Aug 15, 2021 at 19:54


You must log in to answer this question.

Browse other questions tagged .