2

edit: so after an egregious amount of testing, I may significantly narrowed down what the problem might be. So basically, my going theory at the moment is when a large amount of data passes through the adapter, it "trips" off and completely disconnects everything. So first reason why I think this is because, I can consistently get this issue to happen, simply by sending a lot of data (in my case I just spawn in a bunch of TnT, blow it up, and voila, no internet for my PC! Furthermore, the adapter will only disconnect if it is sending a lot of data outside my network. If I connect to the server via a local IPv4 everything is fine, but the moment I join via my public IP, internet magically disconnects).

The reason why I think it is either a problem with my adapter itself, or some issue with windows is because this is exclusive to my PC. I have tested this on another computer connected to the same router, also using ethernet, does not disconnect after large amount of data passes through.

So to sum up, when a large amount of information passes through the adapter via public IP, something "trips off", and completely disconnects my PC's internet until I restart.

---------------------------------- OLD

Hopefully the title describes the problem, essentially when my 1.16.4 Minecraft server runs (with people on it from a different network), after a random amount of time (sometimes it 5 minutes, but the longest I've been able to go is around 4 hours), my internet connection (which is ethernet) will completely disconnect. The server itself is fine (as when I join via localhost, OR local ip address) it doesn't kick me out, but everyone else who connects via my public IP (and when I too join via my own public IP), will be kicked out (obviously right? Since it's my internet that no longer works). In addition nothing irregular with server logs so I'm fairly certain the server isn't the issue, but more so something with Windows 10 and people connecting via an outside network.

I would like to mention that perhaps around 2-3 months ago this problem didn't exist, and only suddenly started to happen when I got a new computer, so this makes me believe that it's something with THIS computer and not the router.

Whenever the ethernet disconnects, stopping the server does nothing, neither does disconnecting the cable. I have to completely restart Win10 in order to get my connection back.

Things I have tried--->

I have tried completely disabling Windows Defender Firewall, and having it on with Java as an exception, neither proved to be the solution. I googled and found this thread, where someone suggested to edit my ethernet adapter settings and change the value of "number of transmit buffers" to 512. (this was already the default). However I don't think this is the issue as regardless if there is one person on the server or 10, the result is the same. This is also an issue with multiple version of Minecraft, (have played on 1.12 and 1.16) which further makes me believe that its not a problem with the server, but more so something with windows.

Here is an image of the network adapter settings

I would like to iterate that this issue only occurs when I'm port forwarding, other than that I have incredibly stable internet regardless if I'm just browsing the internet, in a Zoom call, or playing any other game.

If there is any further information I can provide please ask, but as for now here is what I can think off of the top of my head: Device name -------

Processor Intel(R) Core(TM) i7-10700K CPU @ 3.80GHz 3.79 GHz

Installed RAM 16.0 GB

Device ID -----------------------

Product ID -----------------------

System type 64-bit operating system, x64-based processor

Pen and touch No pen or touch input is available for this display

Edition Windows 10 Pro

Version 20H2

Installed on ‎2020-‎10-‎21

OS build 19042.685

Experience Windows Feature Experience Pack 120.2212.551.0

0

It turns out the Intel 1225-V Network driver chip has issues involving faulty timings for 2.5G operation. (The delay between packets is wrong). This causes intermittent periods of high packet loss. See this report for example.

The reason for your card only experiencing issues when transferring large amounts of data might be power saving options automatically changing its speed.

The problem may or may not manifest depending on the hardware in the Switch or Router connected to your computer. I.e. it may allow the Intel card's out-of-spec behaviour or reject some of its packets. Or it might detect the faulty behaviour and automatically negotiate a lower speed, fixing the problem for you.

Fix

To fix your problems, go to Control Panel > Network and Internet > Adapter Settings, or Right-click your network connection icon located in the bottom-right of the taskbar, select Open network center, then click Modify adapter settings (to get to the screen linked in the Question).

Select the intel I225-V. Right-click and select the bottom option Properties. Click the Configure button below the name of the controller. This should open a new tabbed modal window. Open the Advanced tab. Scroll to the Speed & Duplex setting. It will probably be set to Autoconfigured. Instead manually force it to 1.0Gbps Full Duplex. (If you have really old network equipment or use Cat4 cable then you might need to select a lower speed option such as 100Mbps Full Duplex).

Source

Intel released a bulletin to OEMs (PC suppliers) where they recommended pre-configuring the network driver for 1Gbit operation. Since this is a hardware issue: they are releasing a 'stepping' fix, meaning cards manufactured after Q2 2020, that is past 1 Sept. 2020, are supposedly not going to have this problem anymore. Some users are still reporting problems. This means you won't be able to fix it by updating either drivers or firmware. Instead you may want to apply for a refund or replacement, as after all the card won't operate properly at the advertised speed of 2.5 Gbit. If you do, be sure to inform the place where you purchased of the manufacturing defects or they might supply you with another faulty card.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.