I have a command block hooked up to a comparator that powers some other command blocks. When I have a specific item held in my offhand it emits a redstone output. However, when I go further than 32 blocks from the command block it stops outputting a signal.

I've tried building a chunk loader, I've tried changing the world spawn to the same chunk as the command block, I've even tried using /forceload on the chunk but nothing worked.

Version: Minecraft Java 1.16.2

  • What exactly are the commands you're using? 32 blocks is only two chunks, so should therefore not unload anything Jan 21, 2021 at 13:35

1 Answer 1


It does not have anything to do with the vanilla chunk loading. An active redstone current that is carried out of the player's render distance (into unloaded chunks), will cause the chunk that it is in, to load.

Anyways, you said it stops working further than 32 blocks. The minimum render distance is 2 chunks for java and simulation, 4. The command blocks should definitely load within the lazy chunks. Furthermore, if a redstone current is being outputted by the comparator, the chunk will load for the redstone.

I have a feeling this has to do with the command running in the command block. Check if the command has been limited in the x, z coords (length) (it is usually in the form dx = ... or dz = ...)

If this does not work, try putting a ticking area near the command blocks by the command: /tickingarea add which will force load chunks in the certain area or put a redstone clock: Easy redstone clock, which does same using the redstone mechanics mentioned above.

  • /tickingarea is exclusive to Bedrock and Education editions of Minecraft, /forceload is used instead May 18, 2023 at 14:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .