2

Game is Commander Keen 1, Invasion of the Vorticons (1.31 1/23/90)
Recording using OBS 26.0.2 (64-bit Windows), and DOSBox 0.74-2 (using output=opengl in dosbox.conf)

While recording/streaming, pressing the space bar brings up the HUD. Everything is fine in DOSBox, but HUD is empty in the OBS preview and recording output.

The strangest thing I noticed while writing this up is using ALT + TAB. Moving from DOSBox to OBS, and then from OBS back to DOSBox causes a narrow line of the HUD to render.

Moving from DOSBox to OBS, and then from OBS back to DOSBox a second time causes the entire HUD to render normally.

(Another, perhaps related rendering issue, is that during the end credits -- everything looks normal in DOSBox -- but when watching the recording, rendering will stop mid-word exactly 2 characters before the end of the last line, pause a solid second and a half, and suddenly snap to and complete the line. It does this for every dialogue box.)

Is there anything I can do to fix this rendering problem?

enter image description here

3
  • Have you tried different output options?
    – Mark
    Jan 15, 2021 at 2:13
  • Oh yes. There were 5 listed in the conf file. Tried them all. (Only opengl and openglnb seem to be compatible with capturing output in OBS). Possible values: surface, overlay, opengl, openglnb, ddraw. Jan 15, 2021 at 14:33
  • 2
    After testing on a different computer (same software, same OS), the problem does not manifest itself. (Problem is not solved, but is probably an issue with the Intel graphics drivers on the original machine. It is not the first time I have had quirky problems with these drivers.) Mar 20, 2021 at 0:48

0

You must log in to answer this question.

Browse other questions tagged .