In an anarchy world I created on Bedrock Edition, I spawned in a horse and tamed him, gave him blue leather horse armor, gave him resistance and regeneration (both amplified 255) and named him "Beloved Horse".

Back then, I can leash him along with my friend to cross a river, but now it seems like he's broken.

After trying out the stuff from here to a skeleton, I wanted to keep my horse still on a boat whilst I was on creative. However, the horse doesn't seem to get in. Not a problem, right?

What about leashing to put him in a single spot with a fence, doesn't work either, even in Survival.

Horsey Error

Literally holding a leash, but it is the Ride button instead. What's weirder is that when I spotted another horse, it is leashable.

Like I said before, I can't go deeper because I can't access the in-game code using my phone.

Now I tried the following to try and fix it:

  1. Since my lead is given via command, I decided to hunt down a nearby Wandering Trader to get the lead from the llamas. Still doesn't work.
  2. I removed the saddle and horse armor on him. Still, a Ride button is the result.
  3. I tried crouching, but just like any other tamed horse, an Open button would appear. (If you don't know what it does, it brings you to the horse's inventory.) From @Parkerdaboss216

Will be updated just in case to show if it doesn't seem to work.

It's as if leads don't exist in his world. How can I fix this?


4 Answers 4


TL;DR; My horse was previously leashed but got glitched.

So I've been thinking about this for a while, and since my horse despawned, here is my theory why he's broken.

The anarchy world is multiplayer, meaning my friend and I were the ones playing around with him. It seems that my horse was leashed somewhere else I can't find. When I typed in /tp @e @s to get my horse, it might've had an impact of glitching the horse's behaviour.

It can explain why he can't get on boats nor get leashed, because he is leashed somewhere but got glitched over.

In that case, I regret using that command, but I would still use it for other reasons.


crouch then try and lead the horse

  • 1
    Welp, you tried. Thanks for some advice though. Jan 25, 2021 at 20:31
  • idk much about mobile Jan 25, 2021 at 22:13
  • i play on xbox. Jan 25, 2021 at 22:13
  • They are the same version of Minecraft tho Jan 28, 2021 at 5:11
  • 2
    @TGPMinecraft Device gameplay has different controls for every game, so it's not necessarily true although it is the same version, so @Parkerdaboss216 has a point. Jan 28, 2021 at 13:09

I pushed my horse into the Nether then a phantom lead popped off and pushed him back into the Overworld, I could put a lead on him. Just make sure the entrance of your Nether is safe.

  • 3
    Welcome to Arqade! I would respectfully suggest using proper English and punctuations to make the answer more legible.
    – 54D
    Jan 29, 2022 at 16:27

If you use a controller, just hold the lead in hand, press left trigger, then press left trigger while looking at a fence post. If you play normal controls on mobile (which it looks like you do), then just instead of pressing the ride button, press and hold on the horse, then press and hold on the fence post. Kind of like shearing sheep.

  • The OP can leash other horses, so it is not an issue of not knowing the controls. Feb 18, 2021 at 7:56
  • I know, but you don’t need there to be a button to pop up to press for leashing the horse. Feb 19, 2021 at 22:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .