2

We have 3 laptops, a Windows 10, a MacBook Pro (2020), and a MacBook Air Mid-2014 Both Macs in Big Sur. The problem here is that when the Mac Air hosts the LAN game everyone else can see it, but if the other two try, Mac Air can't see it. The windows and Mac Pro can see each other so the problem is in Mac Air. Also they can ping each other using cmd or terminal 'ping ip'.

I have tried using -Djava.net.preferIPv4Stack=true in the JVM arguments with no success and all firewalls are disabled. Both Mac don't have java installed and they are using the one installed in the launcher (I tried by installing Java 6, 7, 8 and JDK14 before formatting the laptop since I had a lot of trash and could even be a solution)

I know about the direct connect but it is annoying having to type it and the port every time since we keep switching versions to play survival and pvp

Any Ideas? I have tried using other solutions for other similar cases but they are very little and they didn't work.

1
  • Not an answer to your current problem, but seeing this amount of effort put into it, seriously consider installing a regular Minecraft server on one of the computers and playing 'Multiplayer' on that server instead of joining a LAN game. It's far more robust and easier than whatever you've already tried to get your LAN game going.
    – SF.
    Jan 29 at 7:44
0

This is a common bug, the solution is to connect to the other device via the local IP and the port that is put in chat when the game is open to LAN. the server IP should look something like 192.168.0.:. The adress can be found in the Mac networking settings.

4
  • Yeah I knew this trick but is really tedious having to do it every time and even still if I memorize my ip it changes around every week so it's really annoying, that why in the post I was asking for an alternative that can bypass that bug
    – Rocha
    Jan 29 at 5:30
  • Nothing, sorry. I used to play on mac, I tried everything. Macs can connect to other types of devices, but other devices cant connect to the mac when i have tried Jan 29 at 8:32
  • @valkyrie_pilot if that solely is the issue it sounds like a firewall problem. Something must still be blocking connections you don't initiate
    – Penguin
    Jan 29 at 16:46
  • its a thing with mac in specific, I made sure to disable the firewall Feb 2 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.