3

The Kega Fusion emulator full screen mode doesn't work on Windows 10. When full screen mode is started around the half of the screen is in black and the game image is not centered. This is what I get:

half of the screen is in black

I've been working on this for a while and I'm running out of options. I've tried tweaking all of Windows 10's "compatibility settings", but nothing has worked thus far.

Does anyone have an idea for how to fix this?

2

STRATEGY:

We will make some configurations in Windows 10 using its available compatibility modes, configure Kega Fusion and configure and use a tool called DXWnd ( https://sourceforge.net/projects/dxwnd/ ).

WINDOWS 10:

Click with the second mouse button on the executable "Fusion.exe" and click on "Properties"

In "Fusion.exe Properties" window, in "Compatibility" tab, in "Compatibility mode" section, check "Run this program in compatibility mode for:" and select "Windows Vista (Service Pack 2)". In "Settings" section click on "Change high DPI settings" button.

In the second "Fusion.exe Properties" window, in "High DPI scaling override" section, check "Overrride high DPI scaling behavior. Scaling performed by:" and select "System (Enhanced)".

Click "OK" and "OK" again.

compatibility modes

NOTE: These settings are intended to improve performance and increase compatibility.

KEGA FUSION:

Open "Fusion.ini" file. In "Graphics Compatibility Options" section, enter value "0" for "ForceCompatibleGFX" parameter and enter value "1" for "ForceFullScreen32" parameter.

Fusion.ini

NOTE: Under certain circumstances (video hardware limitations?) Kega Fusion changes the "ForceCompatibleGFX" option to "1". When this occurs, the option "Full Screen Resolution" (see below) is unavailable. The option "ForceFullScreen32" with value "1" aims to improve video performance.

Open Kega Fusion, in menu, select "Video", "Full Screen Resolution" and check "1280x800".

Also in "Video" check "Fixed Aspect (Zoom)". "Fixed Aspect (Fit)" and "Nearest Multiple" must be unchecked.

Video

TIP: Also in "Video" select "Window Size" and check "320x240". For some reason this improves video performance in full screen.

TIP "320x240"

DXWND:

Open DXWnd, in menu, select "Edit" and click "Add".

Add

In "Target #1" window, in "Main" tab, enter the name "Fusion364" in the "Name:" field and in the "Path:" field the path to "Fusion.exe" executable.

Also in "Main" tab, in "Generic" section, check "No banner".

Main tab

Also in "Target #1" window, in "Video" tab, in "Window style" section, select "modal".

Also in "Video" tab, in "Window handling" section, check "Set DPI awareness" and uncheck "Emulate Win Maximize". In "Window size & position" section, select "Anchored".

Video tab

Click "OK".

In the main window, in menu, select "File" and click "Save".

Click "Save"

USAGE:

To the scheme work you need to start DXWnd and then start Kega Fusion through the "Fusion364" icon in DXWnd window or just start DXWnd and with it running start Kega Fusion normally.

Usage

Done! Thanks! =D

Done!

1
  • 1
    I followed the steps up to before the DXWnd and it still worked, thanks!
    – plu
    Aug 14 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.