I have been playing Mincraft with my son for last 10 months. We are both using iPad Pro's. And until recently we have had no problem connecting to each other worlds. Then about two months ago, suddenly we are no long able to connect to each other. We can still see each other. We can still start the join process on each others worlds. But every single time, we get the "Unable to connect to world" error.

I have tried everything. I have rebooted the device. Swiped all of the apps out of memory. Signed out and back in again. Tried a third device. I checked the local network switch in settings. We are both on the same wifi network. I check the account settings at xbox live. I even deleted the game and reinstalled it. This is on a local network without any firewall or unusual router settings.

Help! Being stuck at home so much, we are really missing our favorite bonding experience.

iOS 14.3, Minecraft v1.16.201

  • Have you tried LAN instead of the Internet to connect to each other? – Potterton Jan 31 at 16:09
  • The local network setting on the ipads some how had two values. Once I managed to them both set on, on both devices the problem went away. – codingCat Jan 31 at 18:12

Looked at this post (on Arqade as well), and it seems like the issue might be with iOS permissions. In case the link breaks, go to the iPad settings app, go to Minecraft settings, and toggle "Local Network" to on. Also saw a Reddit post that had the same issue and solution. Seems to be because of the new iOS 14 privacy features.

Hope this works, and Happy Gaming.

  • Yea. as I mentioned in my original post, I have checked "Local Network" on both devices, and they both report being on. – codingCat Jan 31 at 6:31
  • @codingCat Oh, I thought you meant in MC. My bad! – Potterton Jan 31 at 16:08
  • Sorry for the snippy response. This actually turned out to be the cause of the problem. One ipad the switch in the mind craft settings off, but not in its list on local networks. And the other one had the opposite, where it was set in local networks, but not in mindcraft. I will have to look into this to see how this single setting could have two values. But thanks for the suggestion, it had me checking the devices for a third time. – codingCat Jan 31 at 18:11
  • 1
    No problem! Glad I could help. For what it is worth. I didn't think your comment was snippy! – Potterton Jan 31 at 18:24
  • I don't think this is new with iOS 14, is it? I feel like it asked me when I got it years ago... or maybe Im just dumb. idk – Penguin Feb 2 at 2:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.