0

I built a set of command blocks on a single-player creative world to work out the kinks, and it worked correctly. It first uses /execute to find an instance of an item with a specific name and teleports the nearest player to a specific set of coordinates, then moves down the chain, using /execute to make the item dropped kill itself, play a sound on the destination spot and play a particle effect on the destination spot. Again, this all worked on a solo creative world.

When I took it to my realms world, I was able to build the command blocks the same way, but the blocks completely forget the coordinates for the destination, replacing them with ### ## ### any time the condition for the first block is met or the editor for the block is re-entered. The only differences are:

  • The blocks in the Realm world are hidden underground instead of on the surface, close to some redstone torches (even though the blocks were marked not to be redstone-dependent)

  • The name of the item was changed for the Realm version. I tried the original name of the item, and it did not fix the issue.

  • I added a ticking area around the blocks so it would function anywhere, and thought that might be the problem, but I removed the ticking area, and it did not enable the blocks to remember the coordinates.

  • In reply to ExpertCoder14's comment: The coordinates in question are 170 67 -22. Not sure why that has anything to do with the profanity filter, but that is somewhat hysterical given the place I am directing the teleport to.

I have another command block in the realm (a small distance away at the spawn point) that is triggered by redstone dust and copies a box of stuff when the correct page in a book is read, and it still functions (without a ticking area because there needs to be a player there to read it).

Here's the initial command: /execute @e [type=item, name="example name"] ~ ~ ~ tp @p x y z

A comment mentioned that it may be a profanity filter issue. The exact coordinates are 170 67 -22, and I am playing on a Switch. Not sure how that violated the filter, but I can try to find a different location for the destination.

1
  • The only censored numbers I know of are 1488
    – Penguin
    Jan 31, 2021 at 18:27

1 Answer 1

1

I think I figured it out: 7 digits could be a phone number. As soon as I add an eighth number, it allows them just fine.

3
  • Why is this account a different one from the one that asked the question? Feb 1, 2021 at 2:10
  • @ExpertCoder14 you've never seen that? IDK about 50% of new users who answer their own questions create new accounts
    – Penguin
    Feb 1, 2021 at 19:01
  • 1
    I intended to ask anonymously, but the only way I could get back to see if anyone posted and answer was to sign up. Sorry if I caused trouble!
    – Codeflare
    Feb 2, 2021 at 20:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .