3

I used the most recent article I could find to help with this and I'm still having trouble. I've triple checked my formatting, doing exactly as the article tells me to, but I can't get the pack to show up in my client. I haven't added any content yet since I want to make sure the pack works. I saw some other posts like this one but I've made sure to check I didn't make the same mistakes. resourcepacks folder my resource pack folderenter image description hereenter image description here I believe it's everywhere it needs to be in my files and it still doesn't show up in the client. (For those wondering the top 2 aren't mine) This is my first time making a resource pack so sorry if I seem dumb.

edit: it might be that my resource pack isn't zipped? But I can't figure out how to zip a file I've created

4
  • Your minecraft version? You have to zip it as well.
    – Phoenix
    Feb 6 at 18:25
  • 2
    @Phoenix You don't have to zip it. Feb 6 at 18:45
  • I don't know if this makes a difference but what encoding are you using?
    – Penguin
    Feb 7 at 7:43
  • I'm not sure what that means but everything I've done is in the linked article
    – JameMhm
    Feb 9 at 22:36
1

Make sure that you have show file extensions enabled, from what I can see, the file type description says Text File for the pack.mcmeta file this is because the actual filename is pack.mcmeta.txt, not pack.mcmeta as file explorer says. In order to actually change the file extension, you'll have to enable show file extensions in the "View" tab in File Explorer. Then remove the .txt file extension.

Ignore any warning about changing file extensions as this is irrelevant due to the fact that these are both plaintext files.

show file extensions

0

If the issue is specifically that Minecraft requires a .zip, and you are using Windows, Windows has a built-in option to zip your resource pack. Just select the folders/files for the resource pack, and then click Send to > Compressed file. There are also various 3rd-party applications such as Winrar, and 7zip that can do this for you as well.

3
  • @Pheonix I can't figure out how to do this, when I zip the files nothing happens, the folders remain the same and the name of the folder does not change to .zip. I might be doing something wrong when I try to compress it though. Since I can't post images I'll try to describe . I right-click my resource pack in resourcepacks from the .minecraft folder. I click 7zip, I press "Compress and email..." and it takes me to a screen with various options. I hit OK without changing anything and the file comes out with no changes. Is there something I'm doing wrong there?
    – JameMhm
    Feb 13 at 2:50
  • You're... trying to email according to the option. Open the 7zip GUI, select the relevant files and folders, then press add.
    – Phoenix
    Feb 13 at 20:05
  • Apologies, I have fixed the problem. I hadn't formatted the pack.mcmeta file correctly. All is well
    – JameMhm
    Feb 18 at 22:40

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .