0

I am trying to host a Minecraft server using a VPN. I live in residence, so I am not able to port forward through my modem settings, I am trying to use the VPN "Private Internet Access" (PIA) which supports port forwarding.

PIA assigns me the port 58180, so I have changed the server to use that port. I have checked the port using this port checking tool and it says it is open.

I can connect to the server with the local address (127.0.0.1:58180), but when I try to connect with [my public ip]:58180, I get the following error message:

io.netty.channel.AbstractChannel$AnnotatedSocketExeption: Permission denied: no further information

I have tried disabling my firewall with no luck. I have hosted a sever before without using a VPN and I know it worked on my machine. I have tried connecting to several different VPN servers all with the same result.

Any ideas as to what the issue could be?

3
  • 1
    Mojang dislikes VPNs if you didn't know. Also maybe your VPN's servers are rejecting the attempt to connect.
    – Phoenix
    Commented Feb 15, 2021 at 4:20
  • Try setting prevent-proxy-connections to false. Commented Feb 17, 2021 at 17:31
  • @MrParrot assuming you are talking about the Minecraft server property I have already done that. Commented Feb 18, 2021 at 19:12

1 Answer 1

-1

That is a very strange issue.

Perhaps your VPN doesn't play nice with NAT loopback/hairpin connections.

Other people evidently can open a socket to your server, as the port checker tool basically does just that (connects to your server, sees if it succeeded, and then immediately disconnects).

See if others can in fact join your server with an ordinary Minecraft client—if they do, you have nothing to worry about.

1
  • 1
    A regular client was not able to join. (it got the same error that I did) Commented Mar 12, 2021 at 18:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .