1

I have recently obtained Borderlands 1: GOTY Enhanced 2019 version. When I start the game after about 30 seconds a long General Protection Fault Error report appears on screen which accepting it, causes the game to be terminated. An in-game screenshot of GPF error report

So I googled around about it and found a few solutions on Steam community, Reddit, Tech forums and other websites including:

  1. Putting the game in list of Windows firewall exceptions. (It was already in there.)
  2. Clean-uninstalling graphic card drivers and renewing drivers for my nVidia GT 740M graphic adapter and I installed newer driver software available for my graphic unit.
  3. Making a copy of a binary .dll file named cudart.dll and renaming its copy to physxcudart_20.dll and keeping both files in binary folder.
  4. finding an original version of physxcudart_20.dll and putting it in Binary folder of the game.
  5. Renewing Visual C++ Redist packages.
  6. Uninstalling and Reinstalling the game in Full Install mode.
  7. Fully deleting Windows 10 cache and fully verifying game's integrity and files 3 times.
  8. Disabling Windows security procedures and apps.
  9. Running the game through Steam in online and offline mode.
  10. Running the game as administrator and compatibility mode (My windows oldest compatibility mode is Windows Vista)

Well, I am not a newbie and I have made many games (with these kind of silly Windowish errors) to work and run. So I follow all these steps, carefully. None of them worked and I'm still receiving the same boring error message.

So, can you think of any effective method to get this work, properly.

Here is my system info:

Lenovo IdeaPad Notebook

OS Name Microsoft Windows 10 Pro

Version 10.0.19042 Build 19042

Processor Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s)

Installed Physical Memory (RAM) 6.00 GB

Available Virtual Memory 3.78 GB

Dual GPU: Intel HDG 4000, nVidia GeForce GT 740M

1
  • I have found a solution different from all these I mentioned above. I'd bought a non-steam retail of the game. I just read people comments about this version and I found an answer... I should have installed it in Steam Common Apps and I shouldn't have changed its installation destination directory. The problem was easily solved by just uninstalling and reinstalling the game into Steam Store folder. – Vynylyn Feb 25 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.