1

I just performed a clean install of Fallout 3 GOTY edition (version 1.7.0.3) on Win10. I want to use mods with it, but can't get a single one to work. It might be important to know that I got it from GOG, not Steam.

I have tried to follow numerous online guides, but none of them helped. I never see any error messages or crashes, the game just starts up with no mods present no matter what I do. All of the guides I could find were for the Steam version of the game. Any time the guides referenced a Steam-based file path, I changed it to my best guess at the equivalent path on my machine, but otherwise I followed the instructions as stated.

To make matters worse, most of the guides I found contradicted each other or even themselves. For example, some said to use Fallout Mod Manager and not bother with Nexus Mod Manager, while others said to use Nexus Mod Manager and not even install Fallout Mod Manager. At this point, I've tried most combinations of Fallout Mod Manager, Nexus Mod Manager, Fallout Script Extender and LOOT. Also, some of the guides were very old and included steps for dealing with obsolete features like Games for Windows LIVE or UAC, which did not seem to apply to me. It's also very possible that some of the changes I made for one guide inadvertently caused problems for my attempts with later guides.

The actual mods I was trying to use tended to be from the group of all-time most popular on Nexus Mods, so they should be relatively stable and trustworthy. I did notice one other weird thing that might or might not be relevant. Multiple guides said it was important to start the game once before doing any modding, so that a base ini file would be present. I did that, and changed a few game options during that first game, like HUD color. After my (failed) attempts to install mods, when I checked the game options, the HUD color and other options were always set back to their default values.

How can I get mods working with the GOG version of Fallout 3? I'm willing to uninstall everything and start from scratch at this point if that would help.

EDIT:
I intentionally did not list the exact steps I took. In addition to being really really really long, I thought they would be too specific to help anyone else. And I might want to change up my mods in the future anyways. This question is intended to be "what are the general steps for installing mods with the GOG version of Fallout 3", not "how do I fix my specific setup".

In particular, is there one mod manager that is known to work well, or one that should be avoided, with the GOG version of the game? Are there instructions that show up in guides that are obsolete and now cause problems (possibly having to do with Games for Windows LIVE) or that are somehow important for the Steam version but end up breaking everything if you follow them for the GOG version?

5
  • 1
    I'd start from scratch. Then, try installing only one mod at a time then check if the game works. Also, use only one mod manager. Try only installing the Updated Unofficial Fallout 3 Patch and only its required mods then try running the game. Currently, it is hard to troubleshoot your issue since we don't know what mods you are trying to install and you are using multiple mod managers. If you install one mod at a time and use only one mod manager, you will be able to easier pinpoint which mod causes the issue. – galacticninja Feb 27 at 6:53
  • Do the mods show up in-game under Data Files? Did you enable bInvalidateOlderFiles in Fallout3.ini (could be useful since your .ini files seem protected)? Can you run the game as Administrator and see if that helps? Have you tried using Mod Organizer 2 (which is IMHO the best mod manager)? – Joachim Feb 27 at 8:36
  • @galacticninja that's actually exactly what I did initially, I just didn't write out the full steps I went through because it would have taken 20 paragraphs and I didn't think anyone else would find my specific case helpful or want to read that much. Even the very first attempt with just one mod and one manager (NMCs_Texture_Pack and Nexus Mod Manager, if it matters) had no effect. I'm asking here because I'm afraid the problem is at a more basic level than a particular mod I picked, like I somehow skipped an important step common to all mod installs. – GogFalloutModder Feb 27 at 15:43
  • @Joachim I'm sorry, I don't understand what you mean by "in-game under Data Files". I did not manually change bInvalidateOlderFiles but did use the "ArchiveInvalidation Invalidated!" tool to get around that. Running as Administrator makes no noticeable difference. I hadn't come across Mod Organizer 2, will check that out next... – GogFalloutModder Feb 27 at 15:50
  • I'd edit your post to start from a completely brand new installation of FO3 (delete the configuration files and directory too). List only the steps you did for one mod installation and one mod manager. The steps shouldn't be that long because it's just one mod. Currently, your question is too broad and it is hard to troubleshoot your issue since you stated that your question is about "the general steps for installing mods". The issue you encountered may well be mod-specific. – galacticninja Feb 28 at 3:00

Browse other questions tagged or ask your own question.