2

First of all, the grammar may be strange because I used a translator a little because I am not good at English.

My Minecraft server(vanilla server) is installed and running on my laptop. I did a test using canyouseeme.org

Testing performed at canyouseeme.org(Edited)

As you can see, the server is being not blocked on port 25565. server-ip on server.properties is blank.

If I try to connect to the server except using localhost, 127.0.0.1 or internal ip address, the connection is denied with the phrase 'connection refused' and there is no word left in the server.log(protocol error, things like that). Connection to the server is being refused both when added and using direct connect.

Things I've tried:

  1. Turn off firewall
  2. Ask others to try connecting to the server(of course, not worked.)
  3. Restart laptop and server
  4. Use a program like Hamachi
  5. Create an Inbound firewall rule
  6. Reinstall the server

I was almost giving up because nothing worked, so this is my last try. If you need any other information, I'll provide it if possible.

3
  • 1
    if restart doesn't work, perhaps completely reinstall? i doubt that would help, but i'm not an expert on things like this. can you check the server settings for any broken stuff? or maybe even try on different computer? – mindstormsboi Apr 3 at 18:05
  • It worked sucessfully on desktop(wired LAN), so I'll try it. Thx – Bero Apr 5 at 3:20
  • When I tried the same server.properties on my desktop, It worked successfully. :( – Bero Apr 5 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.