3

Hoi, I recently bought the Linux version of X3: Reunion from GOG, but I can't find a way to start it.

My system: Fedora 32, 64-bit version

I went via terminal into the X3 Reunion folder and started it by:

./start.sh

Which gave me:

./X3R_config: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

I looked in the folder /usr/lib/ and libgtk-x11-2.0.so.0 was there.

Then I thought, oh, I forgot to install the mentioned programs listed on the GOG page.

Which were:

Requires the following packages to be installed: libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libgtk2.0-0:i386 libxml2:i386 and dependencies. This game comes with a 32-bit binary only

Through internet research I think I found the corresponding Fedora programs and installed them:

  • glibc-devel.i686, which installed libxcrypt-devel.i686 as dependency
  • alsa-lib.i686 (was already installed)
  • alsa-lib-devel.i686
  • alsa-plugins-pulseaudio.i686 (because pulseaudio was the only one installed in the 64-bit version I thought that would be the one for this game)
  • gtk2.i686, which installed atk.i686, gdk-pixbuf2-modules.i686 and jasper-libs.i686 as dependencies
  • libxml2.i686
  • libxml2-devel.i686, which installed cmake-filesystem.i686, xz-devel.i686, xz-devel.x86_64 and zlib-devel.i686 as dependencies

Then I tried to start the game again, this time I got:

./X3R_config: lib/libz.so.1: version `ZLIB_1.2.9' not found (required by /lib/libpng16.so.16)

Through some research I came to this site here: https://stackoverflow.com/questions/48306849/lib-x86-64-linux-gnu-libz-so-1-version-zlib-1-2-9-not-found

and tried the second solution:

cd /your_software/../lib/ (the directory containing libz.so.1)
mv libz.so.1 libz.so.1.old
ln -s /lib/x86_64-linux-gnu/libz.so.1

Because in Fedora is no lib/x86_64-linux-gnu/ I found out that the corresponding folder should be lib64

So I did:

cd /usr/lib/
sudo mv libz.so.1 libz.so.1.old
sudo ln -s /lib64/libz.so.1

Sadly this didn't help.


Recently I had a similar case with the Linux version of Mount & Blade: Warband from GOG, which gave me after start something like this:

error while loading shared libraries: libcurl-gnutls.so.4: cannot open shared object file: No such file or directory

But the solution was:

sudo ln -s /usr/lib64/libcurl.so.4 /usr/lib64/libcurl-gnutls.so.4

And the game started after that normally.

Maybe that helps...


If I forgot anything I will add it, I only use Linux for browsing and some office / gaming, so when it comes down to it, I am only a beginner ;)

Thank you in advance.

New contributor
Gubbel is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

Gubbel is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.