I'm trying to install the free StarCraft 1.8 on Linux using Wine.

When I try to run the installer I receive a message:

".../StarCraft-Setup.exe" not supported on this system

Do I need to install the 32-bit version of Wine for it to run?

Update, after installing Wine 32 bit I can run it, but now I have this error message:

00e1:err:module:LdrInitializeThunk "ClientSdk.dll" failed to initialize, aborting

3 Answers 3


Installed Wine-staging 6.6 and the game is running fine.


I've struggled with this a lot, but ultimately it worked for me out-of-the-box when I tried installing it using https://lutris.net/.

I've installed both the Battle.net launcher and StarCraft Remastered (they exist in the Lutris database already) and it prompted me to install a bunch of "vulkan" things and other related drivers and addons, but it did all by itself and then the launcher just worked.


When in doubt, visit WineHQ's AppDB. It's got all sorts of useful information about running programs under Wine. Support for Starcraft 1.18+ is currently listed as "garbage" (doesn't run), but the rating history suggests that if you can get a copy of Wine 3.15, it should work without trouble.

  • I'm using Wine 5.
    – vodofen
    Apr 15, 2021 at 23:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .