1

I've been trying to set up a bedrock server for myself and a few friends to play on, however, I can only connect to it through LAN. I have already forwarded the port 19132 and that has not worked. Additionally, I've tried using a tool called Ngrok to create a tunnel that allows others to connect without port forwarding. This all worked fine with a java server I ran for a couple weeks.

I later switched to using PocketMine as the server as I thought it could be an issue with the stock server, the issues persisted.

I've tried using different devices on different operating systems (Windows 10, Debian 10 and Arch Linux), but none of them have worked. Both Arch Linux and Debian 10 did not have a firewall installed when testing. When trying to connect to the servers I used an iPad running Minecraft 1.16.221.

I used https://canyouseeme.org to test if the port was open after port forwarding. Whenever I targeted the port that the minecraft server was running on, it errored out with Reason: Connection timed out. I tried using multiple different ports (changed the forwarded port and the port in the server properties file), I tried 25565, 25566, 10000, 22 (might as well try) and 19132. All gave the same error. So I'm presuming that its an issue with the bedrock server opening available ports.

1

Answer moved from body of question:


FIXED: After more trouble shooting, I found that my ISP does not allow me to loopback on my public IP. Hopped onto a VPN on my iPad, entered my WAN IP and it worked immediatedly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.