I have a house in Whiterun and I managed to get a few things for it from the Jarl's assistant guy in Dragonsreach. Recently, I've 'acquired' quite a bit of coin and would like to finish upgrading. Unfortunately, when I go visit him now, there is no option to decorate like there was before.

Now, was I supposed to keep lugging around that stupid interior design book in order for this to be a regular dialogue choice? If so, I totally sold that about twenty levels ago and have no idea where to even start looking for it. Is there any other way to upgrade my house other than the Jarl's assistant? If not, is there a console command for adding that dumb book back into my inventory? Would that even fix the issue at this point?

  • I have the same problem. I picked up my interior decorating book from my home in Windhelm and went back, but it still did not work. So you can count carrying the book around to help, although I did drop it in the first place. Maybe thats it? But like you I didnt want to carry a book around with me (Especially since I had a house to put the book in)
    – user15355
    Nov 26, 2011 at 17:14
  • Are you talking to the Steward in the main hall or in the porch? The latter won't give the option for upgrading your house.
    – Mauricio
    Nov 26, 2011 at 17:23
  • @Kyte I have been asking Jorleif and Captain Lonely-Gale. Neither give me any option to decorate Hjerim. So I will obviously wait, as I have more of the game to play. I have reset my console, waiting 24 hours, gone in my home, picked up the book. Heh, waiting till 8am-8pm time. Waited till Joreif is sitting down. NOTHING!
    – user15355
    Nov 26, 2011 at 17:28
  • @Kyte I've tried both :/ I'll try waiting in front of him for 24 hours to see if that triggers the option.
    – spugsley
    Nov 26, 2011 at 17:39

4 Answers 4


I've found that the Steward can be a bit touchy when it comes to offering the upgrades - the simplest solution is to either wait 24 hours and hope that he moves (and remembers his duties) or simply come back later.

  • When I get home I'll try waiting and see if that works. Thanks!
    – spugsley
    Nov 26, 2011 at 17:40
  • Yeah, seems like his dialogue options are a bit buggy. Simply leaving and coming back to seemed to work just fine. Thanks!
    – spugsley
    Nov 27, 2011 at 13:47
  • My wife had an issue where it had nothing to do with how long she waited in game, but rather closing and restarting the game seemed to bring back the dialog option. Just in case someone else runs into that issue.
    – Sterno
    Jan 13, 2012 at 19:53

Jesse Cox of OMFGcata noticed this problem: it's not exactly bugged, but there are only certain conditions under which NPCs will sell you things: time of day, whether they're in a scripted piece of dialogue, etc.

The issue is that the Stewart won't sell anything to you until he's in the appropriate area, which is inside Dragonreach. If he's having a grand old time outside, you have to wait until he meanders back inside. Once there, he'll sell you all the decorations you can buy.

  • I think this is definitely the case sometimes. I had talked to him while standing next to the Jarl in the Great Hall and the option was still not there. Waiting 24 hours or coming back later seemed the only thing that did the trick for me.
    – spugsley
    Nov 27, 2011 at 14:00
  • Haha I would always try to buy stuff from Adrianne Adviccini while she was walking to Warmaidens Apr 16, 2012 at 22:35

If it is at night and they aren't in the main throne room, then most of the time they won't help you. Try waiting until they go to the main room during the day.


He won't sell you anything on the porch or just before his bedtime. Go see him in the middle of the day when he's in the room with the map or possibly the throne room.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .