32

Yesterday I was testing some button remapping on my controller and saw that you could map "actions" as well, so I mapped the screenshot function to a button to test it.

I activated it, then mapped it back after seeing the notification that the screenshot had been taken, and entered a multiplayer game.

While I was playing, some time later I got a notification that looked like a demon had possessed my Xbox, telling me that the screenshot had been uploaded.

I was unable to take a photo of it because I was busy in multiplayer for quite some time and today the notification is back to normal, so the best way I can describe it is that I used an online "randomizer" to generate some text, and the notification that normally says "Screenshot uploaded to the Xbox network" looked something like this:

S̴͚̒c̴̘͚̑r̵̩͠͝ę̵̰́e̸̤͈͊ṋ̷̯͠s̶̛̱͘h̶͈̭́o̵̞̲͛t̴͔̫͗ ̸̦̑̚ṳ̵̩̿p̶̈́̚͜l̵͖̎ò̶̢̤͆à̷̢͚d̶͈̃̆ę̶͙̿d̷̫̫̿͐ ̸͕̔̀ţ̸̩̾͛o̷̙͔͊ ̴͈̿̉t̸̖͈̃h̸̤̒̈́ê̶͈̪ ̸̡̀̽X̸̠͋b̵̪̀̄o̵͚͚͝x̵̱̪͒ ̵͙̎n̷̠̓e̵̗̠̊t̸̺͙́͠ẘ̵̧̼ǫ̷̋͐r̵̼̯̽k̵͓̬̆̓

It wasn't as bad as the above example but it had lots of these weird accents on every character.

Today the message is back to normal. The Xbox has just been sleeping inbetween, no hard reset or full restart.

Does anyone know why this happened and what the reason was?

This is Xbox Series X.

OK; Scratch "nothing happened inbetween", I now see that there was a system update early this morning. While I don't know if this update fixed anything in this regard, I would assume the console did some kind of restart at the time and my game just continued from Quick Resume.

8
  • 17
    if you had taken a picture, it would have been amazing for r/softwaregore May 21, 2021 at 12:02
  • 1
    I agree, but sadly the notification didn't stay long enough for me to fish out my camera, and due to the multiplayer I was in (dungeon group in Elder Scrolls Online) I couldn't pause for long enough to wait for the screenshot notification to appear. The download runs through molasses when a game is running. May 21, 2021 at 13:00
  • 14
    @Eristheguest Hah, it's already there. May 21, 2021 at 17:26
  • 7
    Did you try to parse HTML with regex? May 21, 2021 at 21:38
  • 3
    Yes, I did, and I was visited by Cthulhu. He did not play nice. May 21, 2021 at 21:48

2 Answers 2

98

Speaking as an ex-Microsoft employee (I worked on Windows), I saw a lot of this, because it's an intentional feature for internal users. We called it "pseudo-localization": it's basically an automatically generated "language" that we used to make sure every piece of text in the program is accessible to the translation team, without going through the expense of actually doing the translations, or the frustration of trying to use our computers in a language we don't understand. The generator just goes through all the text strings (that it can reach), and converts them by starting with the original English text, replacing each letter with a randomly chosen "demon-possessed" equivalent, and then adding about 50-60% extra nonsense (to make sure it still fits in languages like German that tend to produce longer text). If we ever see some text that's still in normal English (because it wasn't accessible by the translation system), or if something doesn't fit or looks terrible, we call up the team responsible and tell them to fix it.

Obviously this isn't supposed to be seen by external users, but it looks like there was some kind of bug and your Xbox temporarily thought it was in this "pseudo-locale". I agree, it's pretty funny to see!

6
  • 7
    I saw it in a youtuber's (Enderman) video. It looks so WIERD! Also I like the fact an ACTUAL ex-Microsoft employee came to answer this. May 21, 2021 at 17:28
  • Though I don't have any way to verify any of the claims in this post, I think it is entirely plausible because we've used a similar method to make unlocalized text "painfully" visible to our testers in a product I used to work on. Basically we replaced all symbols in the text with a different unicode symbol that looked the same, just upside down. You could still read the text, though not easily, but it bugged testers enough to report it so we got it fixed. Here is an example, "ǝʃdɯɐxǝ uɐ sı ǝɹǝH", though I do believe we still had the letters "in the right order". May 21, 2021 at 17:35
  • 4
    @LasseV.Karlsen I've seen this claim elsewhere, by others claiming to be current or former Microsoft employees; I think it's probably legit.
    – wizzwizz4
    May 21, 2021 at 18:44
  • 4
    @LasseV.Karlsen since the question mentioned that "it had lots of these weird accents on every character", I'd believe this is the case of pseudo localization, just like what Android also uses.
    – antimo
    May 22, 2021 at 5:47
  • I'm also ex-MSFT and I can also confirm the pseudolocalized text is a thing - though I haven't seen people use it since Windows 8.1's development (but I wasn't in OSG, so my experiences are limited - in fact when my org was dogfooding Windows 10 in early 2015 I don't even remember it being an option anymore...)
    – Dai
    May 24, 2021 at 16:10
2

It was just a bug and the update has fixed it.

5
  • What update? None is mentioned in the Q. May 23, 2021 at 0:05
  • The restart not update
    – iMxqh
    May 23, 2021 at 4:48
  • No he does say there was a restart
    – iMxqh
    May 23, 2021 at 4:49
  • @iMxqh They specifically say there has been no restart. "Today the message is back to normal. The Xbox has just been sleeping inbetween, no hard reset or full restart." May 24, 2021 at 18:12
  • OK; Scratch "nothing happened inbetween", I now see that there was a system update early this morning. I meant system update.
    – iMxqh
    May 25, 2021 at 21:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .