1

I used to have a Windows 7 install and Gameranger worked just fine; I recently installed Windows 10 Ameliorated and now Gameranger tells me:

There was no response after contacting the GameRanger server

Things I've tried:

  • Restarting my computer
  • Verifed I can ping Gameranger.com
  • Using both Ethernet and Wifi
  • Setting my network to Private or Public
  • Connecting on Linux (I have a dual boot computer) works
  • My computer clock has the right time
  • Adding my User to the administrator group
  • Running the program as administrator
  • Allowing the app through the firewall
  • Reinstalling Gameranger

Does anyone have other ideas? Thanks!

5
  • 3
    From what I've found, "Ameliorated" is a pirated copy of Windows 10 with 2 GB of apps and services removed, including Windows Update. My guess is Gameranger relied on one of those removed services. And given how "Ameliorated" was taken down, you're very unlikely to get any support other than "use the official Windows 10".
    – Nolonar
    Jun 3, 2021 at 14:37
  • @Eris the guest - Not that it's relevant to the question, but I own a copy of Windows 10, it's simply too slow to even surf the web.
    – Dr-Bracket
    Jun 3, 2021 at 15:29
  • I’m voting to close this question because it's asking for help troubleshooting illegal software. (per Nolonar's comment)
    – pppery
    Jun 3, 2021 at 17:18
  • Comments are getting off topic, but afaik Ameliorated is legal
    – Dr-Bracket
    Jun 3, 2021 at 17:28
  • 1
    Valid point. I've retracted my close vote (I was going off of Nolonar's claim, without attempting to verify it myself)
    – pppery
    Jun 3, 2021 at 17:38

2 Answers 2

1

the missing components are apparently advertising Chrome based I think but cannot be sure, because I do not know what the files are exactly used for. With trial and error I found out what gameranger needed to have to function, in my test you can still register a new account all that gameranger needs are these components function properly see link.

https://drive.google.com/u/0/uc?id=1eLkgAIcMKHjfxXE9pcDdhS3yl7zuHvHJ&export=download

to install go to C:\Users\ your username \AppData\Roaming\GameRanger\GameRanger Prefs then overwrite components.

I found an intriguing little thing on YouTube

apparently when you use a proxy it works so I don't quite get what's going on but it is indeed weird.

1
  • Proxy worked. I had to hit "Connect" like 30 times (each time it got like 2% more done), but it worked!
    – Dr-Bracket
    Jun 13, 2021 at 16:49
1

By the comments: Ameliorated possibly removed a component GameRanger needed. Best solution: Just use normal win10! I'm sorry if it's laggy as hecc, but you will need it if you want ANY real support!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .