Ok so whenever I try to join any Minecraft server, I can not:

  • Load chunks (Chunks I loaded before this issue show up normally)
  • View skins (Skins I loaded before this issue also show up normally)

And I have tried everything to fix this problem
Things I have tried:

  • Reinstalling Minecraft
  • Reinstalling Java
  • Running antivirus to check for malware/adware
  • Turning off antivirus and firewall
  • Adding minecraft to exclude lists on antivirus
  • Allocate more memory to minecraft (Resulted in my game crashing)

One thing I also noticed is when I try to use gradle for java it does not connect. For example when I try to use Mcreator it just fails to connect, or when I tried to build gradle in intelliji for making a fabric mod it just said Connection timed out: no further information.

Can anyone please tell me what is going on? This is super annoying.

EDIT - More problems (1.17 does not install):

I tried installing 1.17 and it failed, here is the error message:

Name: blocklist-1.0.5.jar
URL: https://libraries.minecraft.net/com/mojang/blocklist/1.0.5/blocklist-1.0.5.jar
Error details: Failed to connect to libraries.minecraft.net port 443: Timed out
Filename on disk: blocklist-1.0.5.jar
Path: C:\Users\(my name)\AppData\Roaming\.minecraft\libraries\com\mojang\blocklist\1.0.5\blocklist-1.0.5.jar
Exists: Nonexistent

This probably has something to do with it, because I have never had trouble installing new versions before this issue.
I thought maybe something was blocking libraries.minecraft.net, but after adding it to my antivirus's ignore list and turning off my firewall it still did not work.

This problem is really beggining to get on my nerves, my friends are starting an smp that I want to be part of, but I can't because I can not play 1.17 or load chunks on older versions. I would be very grateful for anybody who would help solve this problem (I will be adding a bounty as soon as I can).

  • 1
    Have you checked your own internet? Sounds like your internet is struggling.
    – Phoenix
    Jun 10, 2021 at 1:21
  • 1
    @Yek It has to be your internet, or maybe it is because you might have not allocated enough memory to minecraft. Try increasing that, and also try to change mc versions and launchers to check if the issue is with a specific installation.
    – RyugaGod
    Jun 11, 2021 at 9:21
  • 1
    @Yek how much RAM did you allocate and how much do you have total (probably 8 or 16 GB)
    – Penguin
    Jun 11, 2021 at 23:29
  • 1
    @Yek who hosts the server? the blocklist jar is a plugin that needs to be put in the plugins folder of the server. Why is this in your libraries? Also, is the jar file downloaded from here? : spigotmc.org/resources/…
    – RyugaGod
    Jun 12, 2021 at 15:53
  • 1
    I may be dumb, I do not know what blocklist is, I just searched it up on google and this came, if I am wrong then pls tell what it is, and how it works, and from where you got the jar.
    – RyugaGod
    Jun 12, 2021 at 15:57

1 Answer 1


The problem has been solved... kind of?

So I recently remember that I had this problem with Roblox a while ago. Roblox would only work when I used a VPN. So I thought this would maybe work with Minecraft too, and it does.

I have no clue why I need a VPN to use Roblox and Minecraft, but it works I guess.

It is annoying how I will have to turn on my VPN whenever I want to play Minecraft, and I would still like to find the reason this is happening. I might just leave this problem as unresolved because it is still a problem, and maybe at some point somebody will know why this is happening and leave an answer on this post.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .