2

I am having two problems with custom models in my resource pack. I am not sure, but I think that they are related. I have looked everywhere and found this and this.

you cannot give a solid block a model like that

Is there any way of fixing it? Here is a screenshot with both problems: tree problem

2
  • 1
    I can't seem to infer what problem you're trying to solve. Well, at least not with 100% accuracy. Are you asking for help with the fact that your block has a base color that is not grass, and therefore stands out? That's the only issue I see. Commented Jun 24, 2021 at 17:55
  • @Tacoタコス I want to solve the problem that the diagonal sides are dark and that when you look under it you see void and not grass.
    – EmojiMaker
    Commented Jun 24, 2021 at 22:50

1 Answer 1

2
+50

As the post you linked specifies, due to how Minecraft renders textures, blocks which should be solid will remove textures connecting to other solid blocks. It's why the post has a screenshot showing why a slab works, but not solid dirt.

Your best bet would be to, maybe, create a texture for the bottom, or simply not use that model.

3
  • Is there any way of fixing it?
    – EmojiMaker
    Commented Jul 9, 2021 at 21:40
  • as i said, your best bets are only to make a texture of some form for the bottom or to not use that model
    – xTerrene
    Commented Jul 9, 2021 at 22:39
  • OK. But how do I make Minecraft think that it was never a full block in the first place?
    – EmojiMaker
    Commented Jul 12, 2021 at 23:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .