I am at the point where I am to "Lead someone to the shrine and slay them."

I have a companion following me and have lead them to the shrine but nothing is happening. What am I supposed to do? Does it only work with certain NPCs?


5 Answers 5


It could be one of two things: The follower you're using, or what you're doing when you get there.

I noticed some of the followers wouldn't do what you needed them to do. One example being one of the Dark Brotherhood initiates. I've found it works best with one of the mercenaries you can hire from one of the main cities. I used the one in Solitude. A nice list put together by the guys at SegmentNext can be found here. It shows where they are and what their names are.

When you get to the shrine with your follower, you want to talk to them and use the option "I need you to do something." Your cursor will then change, as will the action you're performing. Simply look at the shrine, and it should say "Activate sacrifical altar" or something along those lines. An animation should show your follower walking to it, and then being attached to it. From there, simply kill them by any means, the Sacrificial Dagger works, but is not required.


The Dark Brotherhood initiates will not work for this quest. They simply will not activate the pillar.

The best person and the cheapest, is found in Markarth:

  • At the Silver Blood Inn, challenge Cosnach to a fist fight
  • Win 200 septims (100 plus your 100 wager)
  • Travel back to Shrine after asking him to follow you
  • Speak to him, and ask him to do something
  • Highlight cursor on Shrine (must say Activate Pillar of Sacrifice)

He walks over, and... I won't spoil it.

hope this helps.

  • It's okay to spoil it if you use spoiler tags (put a >! before each line) Jul 2, 2012 at 0:53

Press 'E' (or the action button you have) to bring up the companion menu, then select 'I need you to do something'. Then all you have to do is select the pillar in the shrine (again with whatever action button you have designated). After that, they will become attached to the shrine, and you can slay them. You do not need to use the weapons they give you to slay them.

The uesp page for the Boethiah's Calling quest also tells you this, if I was unclear.


My follower didn't react much on the command on touching the pillar , so I let him pick up the goblet on the floor near the pillar as a test. Afther he picked the goblet up , I again gave him the command to touch the pillar and it worked fine . He then was pulled to the pillar.


Mjoll the Lioness cannot be sacrificed in this mission either just thought I'd add that! I wound up hiring a mercenary and sacrificed them that worked just fine!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .