2

I run a Minecraft 1.17.1 server on the same machine but when I try to connect to it I can't, while everyone else can join it. I'm connecting to localhost:"port". When the server was still in 1.16.5 it worked just fine. I have my firewall disabled.

This is the error that I get when I try to join.

enter image description here

I think it is some kind of client issue because when I try to use 1.17 to connect to the server (that is in 1.16) I get the same error, not the outdated one.

2
  • I don't know much about networking but try localhost as the address
    – c1uq92
    Aug 6, 2021 at 19:54
  • localhost:port should work on the same machine. If the port is 25565, you can safely omit it.
    – MrParrot
    Dec 5, 2021 at 17:19

1 Answer 1

-1

You can either put 127.0.0.1:{port}, 192.168.1.1, localhost (try it without a port this time), or your public IP.

If that doesn't work just make sure you're using the normal launcher and have 1.17.1 (Not 1.17 it won't work).

2
  • Thank you but i get the same error if i try them(but with the difretnt ip at the end.) but if I use the 192.168.1.1 one it waits a bit and then shows the errror not like the others, and yes im in 1.17.1.
    – elek
    Jul 7, 2021 at 15:23
  • Do you have online mode as true in the properties file? Jul 7, 2021 at 20:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .