6

My son plays Minecraft Java Edition on Kubuntu 20.04. Up until recently (a couple weeks ago), it would always log him in automatically. Then, it stopped doing this, and prompted him to choose "Microsoft account" or "Mojang account."

Also, in the course of trying to sign in with the Microsoft account, "X" would pop up a zillion messages saying "the password you use to log into your computer no longer matches that of your login keyring." (No, the unix login password was never changed.) I got rid of those messages by deleting (actually moving aside) the file ~/.local/share/keyrings/login.keyring; the next time we logged him into the Minecraft launcher with the Microsoft account there was a system prompt to enter a password with which to create a new default keyring, so we put in his unix login password for that on the basis of the earlier error message. (The new keyring had "Default" in the name; it wasn't called "login.keyring" anymore but I don't think that's important.)

This seemed to work fine, the launcher showed his Minecraft name in the list and after clicking it, he got the normal launcher screen with a big "play" button.

However, I wanted to test further so I logged out of his Linux account and logged in again. After that, starting the Minecraft launcher newly again showed the "Mojang account" or "Microsoft account" choice, i.e. he wasn't kept logged in. Maybe the keyring wasn't unlocked?

Does anyone know how to permanently resolve this? So far as I can tell nothing was changed locally between the time when it was auto-logging him in and the time when it started prompting for Microsoft sign-in every launch.

(Although, one thing that occurs to me is that it's very rare for him to log out of the Linux account rather than just lock it and put the computer to sleep, so maybe there's some step that needs to happen to unlock the keyring after he logs in? But I don't recall ever doing that before, and he's played for months; I don't think two weeks ago was the first time he's signed out the Linux account since starting Minecraft for the first time.)

5 Answers 5

2

I'm having the same issue on Fedora 34 since the last launcher update.

Launcher 2.2.355X login process is being updated so I guess this is the cause.

We'll have to wait for the next launcher update to resolve this.

2
  • Welcome to arqade.se ^^ Take the tour and read the help center if in need of guidance at any time.
    – Zoma
    Jul 19, 2021 at 8:10
  • Do you know if the launcher auto-updates itself whenever it's opened? I don't remember ever doing anything to update it before.
    – Wildcard
    Jul 19, 2021 at 17:47
1

So it seems I had the same issue. I just solved it by installing gnome-keyreing on my Kubuntu 20.04. Hope it helps you too.

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 28, 2021 at 18:25
0

Apparently changing passwords helps. I tried it didn't work but it might work for you. But I think its because they are trying to get java players to play windows 10 edition.

0

There's a few possible problems here. As you've noted a previous problem with the keyring, the way I've solved this problem is to delete the entire ~/.local/share/keyrings directory and re-create. I had a similar problem before where the keyring needed to be unlocked everytime, and had solved that but then ran in to this problem with a more recent launcher update, and it persisted through Microsoft account migration. Deleting the keyring and re-creating it has solved the problem. I suspect there was some mismatch between the default keyring used and multiple rings being available. As there was nothing useful stored in the keyring, this was easier than trying to change the keyring used, which would be the most correct answer.

0

Use ATLauncher, it works very well for me. I had the same issue and it's now gone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .