I have an issue with my game, don't remember what suppose to happen but after entering Drowned Temple and clearing it down I have no quests, no markers, no objectives and I'm pretty much stuck. What should I do next?

enter image description here

enter image description here

Restart / reboot didn't help, trying to reinstall game altogether.


1 Answer 1


At the end of the temple after clearing it, you're supposed to find the 2nd sword fragment of the stranger (exactly where you're standing on your screenshot).

After taking it, you're supposed to bring it back to Deckard Cain in New Tristram.

Here's a site that lets you check every step of The Broken Blade quest.

If there wasn't the sword fragment in Drowned Temple or that there isn't an ongoing event when back to New Tristram, it seems that your game is bugged.
In this case, you should try to stop and launch again the game.

  • Can I edit this post instead of creating one? Jul 19, 2021 at 16:21
  • 2
    @BartekMalysz if you have an answer, you'll want to create your own. Jul 19, 2021 at 16:29
  • 1
    @BartekMalysz If you have found the solution, then you can create another answer to this question. That's perfectly fine.
    – Sjoerd
    Jul 19, 2021 at 16:58
  • @BartekMalysz Have you tried to check that every previous step before getting the fragment was well done? You might want to try and go back to check if Lea did give you the quest properly. If this still doesn't work you might start the quest over through options before starting the game, where you can select your character. I'll check tonight the exact options to reset a quest on PS4 and add this to the answer. Also sorry for suggesting you create a new question, seems like it wasn't a good idea :/
    – Zoma
    Jul 20, 2021 at 7:52
  • 1
    @Zoma You can see this Arqade Meta Q&A for more details on what the best course of action is.
    – One 2 Many
    Jul 22, 2021 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .