2

My Pokemon White 2 cartridge will not load the save data, nor can I delete it because it softlocks on:

The save data could not be accessed. Please turn the power off and reinsert the game card.

I tried that, but it didn't work. I also cleaned the tips with isopropyl alcohol... and it yielded no result.

Up+Select+B doesn't work because, once again, I can't get to the title screen.

What on earth do I do? Go into Godmode9i and destroy the save? Back up the cartridge? Some other secret combination?

2
  • I'd suggest looking here. This issue seems to have been around for a while. If you do take advice in that article, please do not lick your cartridge. Even if the moisture does bridge the connection, you'll make your situation worse by causing corrosion on the pads. My personal advice is to also open up the cartridge and check for corrosion. Here is an instructional video on that.
    – Regnegade
    Jul 26, 2021 at 13:52
  • @Regnegade None of those have worked...
    – WG481
    Jul 26, 2021 at 19:20

1 Answer 1

1

From similar reports online, it sounds like the issue is most likely caused by either corrosion of the electronics inside the cartridge, or small hairline breaks of the gold contacts on the cartridge. Either of these reasons can cause the DS to not be able to read data off the cartridge properly.

Like Regnegade mentions, I don't recommend licking the contacts in an attempt to 'bridge' the connection. Your best bet is to take the cart to an electronics repair shop. Explain that you think the issue might be corrosion or a broken contact, and have them investigate from there.

Of course, if you are handy with electronics, you can attempt to clean off corrosion or fix broken connections yourself, but given the small size of the DS cartridge this may be harder than it looks. If you have no experience with this sort of thing it's best to leave it to the professionals.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .