I have a DS4 controller and I've installed DS4Windows by Jay2Kings and my controller worked until I decided to upgrade it to the ryochan7 version. The controller was obviously disconnected so i had to reconnect it to my PC, I think the last time it worked it connected as a "Everything Else" but this time it was only found in "Bluetooth" as a Input and it isnt showing up in the game controllers panel, nor is it detected by steam. All my config supports on steam are disabled. I have tried just about everything to fix this. Reinstalling my drivers (HID Game Controller), Reinstalling DS4Windows, Reinstalling HIDGuardian, Disconnecting and Reconnecting it, Changing the Hardware Registry and running DS4Windows as Admin.

TLDR : The controller is connected but isnt detected by anything else. It has a white lightbar while connected, it does not disconnect spontaneously. On USB, It has the same drivers with additions of mic and sound. It now has a breathing yellow/orange lightbar.

This doesn't seem like any other issue, so thanks in advance.

1 Answer 1


On Windows, the Dualshock 4 has genuinely native support, being set up as a Wireless Controller. Most STEAM games will very explicitly state if they support controllers, in which they will have native functionality mapped into it, with no need for external tools like DS4Windows, an unneeded tool already.

If your game doesn't natively support the any controllers, or runs in a keyboard only setting, I would map it with Xpadder, as it uses DirectX to map the controller to keyboard keys. DS4Windows has never worked for me, yet Xpadder has done the job thousands of times.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .