1
E:\Minecraft Server\mcserver1171-optpre32>java Xms2048M -Xmx2048M -jar server.jar nogui
Picked up _JAVA_OPTIONS: Xmx512M
Error occured during initialization of VM
Initial heap size set to a larger value than the maximum heap size

Every time I've attempted to launch my server today, I've received this message. I had this same issue yesterday and deleted the environment variable causing that, and it worked that day. I shut down my machine at the end of yesterday, and decided to test my server again today (I only intend to invite other people on it tomorrow) to test altering the seed, only to discover that this error is back. I've checked my environment variables and there is no _JAVA_OPTIONS variable. Where is this alteration coming from, and how do I fix it?

3
  • Welcome to arqade! I recall having this issue as well and it being a direct response to having the wrong version of Java installed. Go ahead and uninstall Java and then go here and get 64-bit java. If that doesn't fix it I'll look into it more directly and draft an official answer.
    – Regnegade
    Jul 29 at 13:00
  • 1
    @Regnegade Thanks, that worked! Strange issue there, since I do remember installing 64-bit java. Maybe because I had an environment variable at the time I installed java that time.
    – rybob
    Jul 29 at 14:36
  • Gotcha, I'll post an answer with this, if you could mark it as the solution it'll help people in the future, glad it fixed it!
    – Regnegade
    Jul 29 at 14:44
1

This issue can be caused by having the wrong version of Java installed. Uninstall your Java installation and go here and install 64-bit Java. This should fix your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.