4

Playing Forza Horizon 4 on Xbox series X, I tried to download and apply an online design to my car. The game displayed the "downloading and saving the design" message... but it got stuck there. After a couple of minutes I gave up and restarted it from the Xbox menu.

Now, when I start the game, it cannot complete the loading screen. It's not frozen, my statistics keep rotating on the bottom... but it never loads.

I tried, without success:

  • Waiting over 10 minutes, in case it was just slow.
  • Hard resetting the Xbox (completely shutdown, then wait a couple of minutes and reboot).
  • Deleting my data and resync'ing from the cloud.
  • Deleting and reinstalling the whole game and the DLCs.

How can I fix this?

1 Answer 1

3

This is a bug in the way that Forza Horizon 4 manages the save files. It only affects the Xbox Series S/X version of the game.

If you have access to a Windows 10 PC or an Xbox One console, you can fix the issue by following these steps:

  1. Fully close the game on your Series S/X console.
  2. Load your save on an Xbox One or Windows 10 PC, using the same Xbox account, and make sure to load your data from the cloud.
  3. Do something in game to trigger a save, such as changing cars, changing houses, updating difficulty settings, completing a race, etc.
  4. Return to free roam. There should be a spinning circle in the lower right in free roam when the game is saving. Wait for this to complete.
  5. Fully close the game.
  6. Back to the Series S/X console, delete your local game data (make sure you don't delete your cloud data!!!).
  7. Attempt to load the game again on the Series S/X console.

There is more info on this forum thread.

The steps above were provided to me by the Forza support team, so I guess it's the only workaround available at the moment. They also instructed me to remove any keyboard or mouse I could be using with the Xbox, but I had none.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .