5

This has been happening for 3 days now. I start the game and nothing happens, all it does is to inform me that I am in Offline Mode (I have limited internet access, so I cannot reinstall the game either). On the first day, I just went into online mode for a bit and it worked. The second day I had to restart my PC but today, none of them worked. I tried the following:

  • Verify the files
  • Search all the internet for solutions
  • Start through steam, through steam://rungameid/322170 and through C:\Program Files (x86)\Steam\steamapps\common\Geometry Dash\GeometryDash.exe
  • Reinstall the monitor drivers, just in case it had started.
  • Try to find out if it didn't even start, and it didn't
  • Run it in compatibility mode

I also found a solution to use by going to %localappdata%\GeometryDash and deleting CCGameManager.dat, but I prefer not to because I have an un-backupped 20k-objects level.

Please help me

1 Answer 1

3

If you are reading this, DO NOT RETRY TO OPEN YOUR GAME! Read the FULL post first.

While I was writing this question, I thought that CCLocalLevels.dat might be the local levels. So, I copied all the CC*.dat files and pasted them in a different folder. Then I deleted all the files in the GeometryDash AppData folder and restarted the game. The CCLocalLevels.dat file changed from 30MB to 1KB and that was the most stressful moment of my last 5 years. I stopped for a bit to think clearly:

If there is both a CCLocalLevels.dat and a CCLocalLevels2.dat, then the second one might be some kind of backup. Now, what I think that happens is that the second file gets overwritten every time you save, create or delete a level. Later, I started to search for how to fix the broken files, as the only backup I had at that moment was CCLocalLevels2.dat, but it still didn't work properly, provided that the game deleted the file on its own.

After some research, I came across this cool little software that fixes your GD files (link). I instantly understood what it did so I copied the CCLocalLevels2.dat, the CCGameManager.dat, and the CCGameManager2.dat files and pasted them in the %localappdata%\GeometryDash folder. Make sure not to cut them, that's how I lost my first set of backup files. The program then told me that it successfully repaired all the files, but it didn't find the CCLocalLevels.dat file (the lost one).

Now, if you try to download the software and paste the broken files in there (make sure to keep backup), the game should start and your levels will still be there. If you don't want this to happen ever again, just make sure to back up your files on the cloud (or locally) and close the game by its own X button (in the main menu). What happened to me was to close the game using Alt+F4 or just turn off my laptop without closing the game first. All this problem started from my laptop not having a battery (it's broken. I only have its charger).

2
  • Hey Ath.Bar, would you like to mark your answer as accepted?
    – Timmy Jim
    Commented Sep 8, 2021 at 14:33
  • Yes, thank you for reminding me. I wanted to do it 2 days after I posted but I wasn't able to access the internet for some days...
    – Ath.Bar.
    Commented Sep 11, 2021 at 11:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .